What's the best miner for C31 algorithm?

I will add C32 support once I have some spare time and access to a 24 GB card like the Titan RTX.
Btw, I’m heading to San Mateo, not San Diego:-) But thanks.

Haha sorry, thats what i meant to say: San Mateo. For the meetup.

Hi @tromp !

Let me know if you need access to a V100. I can ssh you in if you are working on this in the next 2 days.

yes, i’d appreciate ssh access to a V100 in the next 2 days. although i can’t predict when i’ll have chance to use it in these 2 days…

I am trying now to start grin-miner (downloaded precompiled binary) on Ununtu 18.04. This is the status:

What am I doing wrong? My .toml file is:


An error messages are like this:

Jan 25 11:43:11.058 DEBG Mining: Plugin 0 - Device 0 (GeForce RTX 2080 Ti) Has ERRORED! Reason: Device 0 GPUassert: out of memory /home/travis/build/mimblewimble/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckatoo/mean.cu 429

Just guessing here, maybe you have a monitor connected to this card? Also why did you have all those settings commented out?

do you mean that the miner will work without monitor?

I have checked it - Ubuntu has booted up without any monitor attached. The same result and the same error messages.

p.s. C29 is woking though:

reboot linux in text mode, no GUI, it is eating your memory, do a google search for ‘run level 3’ , this will run it in a terminal and not launch the x-server (graphics)

basically hold down the left shift button as you boot, it should bring up the grub boot menu. press ‘e’ to modify the boot paramaters. Then move the cursor down until you find the line that begins with ‘linux’ then hit ‘end’ key on your keyboard to get to the end of the line. Then put a ‘3’ at the end of that line. (be sure to include a space before the ‘3’) then hit F10 to boot with those parameters.

I bet that’ll fix your problem.

PS it only survives for one boot. if you want to make it a permanent change, so it always boots like that. have a look at https://www.howtogeek.com/howto/43471/how-to-configure-the-linux-grub2-boot-menu-the-easy-way/

dont need to go out and modify grub, just run sudo init 3 in a terminal and ull shutdown x, relogin and start the miner

1 Like

Have you ran nvidia-smi to see what information it reports about the card? Specifically does it have enough free VRAM for the C31 algorithm solver you have chosen? So far, I am in agreement with everyone who has replied to you.

which Miner you are using for C31 algorithm?

in this way, how can modify GPU settings as fan speed, core and memory clock?

You can use my Workstation with an Titan RTX. I could setup a Ubuntu 18.04 USB OS.

@dwayne @ximae @babaji Thank you all a lot, it works! :smiley:


cant use nvidia-settings without x. You can use nvidia-smi though, havent managed to overclock with it it tells me my card isnt compatible but u can try out, i think u can manage fan speeds with it and u can def set ur power level with it, thats what i do.

i was able to managed power limit with nvidia-smi but i was not able to manage fan speed. just moment i look at another software like lm-sensors and fancontrol

Do you have 1080tis and 2080tis on the same rig ? I don’t know why, but I got 1 RTX + 4 GTX on one rig, and I can’t make them work together. The hashrates go crazy and the miner freezes after some minutes. Ubuntu 18.04 + cuda10.

Everything is fine if I use the RTX only, or the GTX only.

How could you solve this problem? I’ve got same situation.

in the terminal type “sudo init 3” or enter ctrl+alt+f7 (it will close the gui) when you are in the CLI run the miner.

There is another option that could be possible. Your PSU is not strong to support 2 cards or your PSU does not run power through 2 rail