Mining c29 and c31

If i have two cards 1070ti and 2080ti . Can i configure 1070 to run c29 and 2080 run c31. Or will that cause issues?

Also 2080ti running c29 is hitting 6Gps while c31 is 1.7Gps. But not sure i dan directly compare these.
Thanks

Check out this handy form: https://grin-pool.org/what-to-mine/

From the info you provided, you should be running c31which may yield ~3.461 grin per day

You should most likely be running C31 on both

Thank you. One more question.
Do you have register on sparkpool to mine grin. Will grin i help mine be sent to whatever email i place in stratum_server_login field?
Thank you.

I think i figured it out. Thank you.

did you try with C31? If so, whats your performance?

I get 1.7Gps but having issues with sparkpool.
https://forum.grin.mw/t/c31-erro-failed-to-submit-a-solution-rpcerror-code-10-message-invalid-share-invalid-algs-31-for-grin-29/2705

Hey, how did you manage to mine c31?

I have an old Titan X (Pascal), uncommented the options having to do w GTX 1080 ti ,commented the CPU options and the miner can never pick up the plugin and start mining.

I am running Ubuntu 16 w CUDA 9.2 and nvidia-396

When I uncomment the CPU mining it picks up the plugin and starts mining on the pool. With my GPU it never even start.

Two things verify before you build your compiler is using gcc-5 and cango.toml you have cuda uncomnented. In your output directory target/release or target/debug verify in folder plugins you cuda you want to try. In grin-miner.toml is in same directory as grin-miner. In that file is where you define path where plugin is located. For me it just plugins. Hope that helps im unable to include my config will do later tonight. Also change log type to debug tail -20 ./grin-miner.log file to see whats happening.

Used the precompiled version. So you tell me that I better compile my own because there are issues with the precompiled one? That would be … irregular. But OK I ll give it a try. BTW yeah I have all the requirements to compile it succesfuly. I just find it strange that they didn’t bother to compile it sucesfully themselves.

OK thank for the tips.

Hi there, mining c31 with the mean cuda c31 gtx plugin on grin-pool.org. Located in Germany. 6.9 graphs/s.
With 12x Asus turbo 1080ti on Linux.

MW, robbie, what the CPU are you use in rig? my pentium can not even launch three 1080ti cards (100% load)… hashrate on grin-pool and on rig is equal?

I changed it. It is now i5 7600k with b250 Asus mining board. 8gb internal. With smOS on Linux and it is very stable on grin-pool. org

there is a decrease the available GPU memory in Linux. this way, it is less than 11G and miner gives error. how can i optimize xorg.conf to reduce memory loss?

Depends on which card. For example, I have the original Asus turbo which has 11,1xxgb but there are also aftermarket 1080ti’s from other brands and they have 10,8gb or 10,6gb.ask your miner to decrease the required memory for c31

my cards are Palit JetStream 1080ti with 11264Mb (11G) I guess problem is in X screen settings

Yeah same issue -here- too. I can mine when I boot to my OS shell-only, however I cannot mine when I boot an X server (it errors out).

If anyone knew how to fix this it would be great. Is there a setting on the miner to ask from the card slightly less memory than normal? Merely enought to boot.

have u tried using a lightweight desktop like lubuntu, or just swapping over to lxde desktop?

what kind of error do you get?

Hey, I have a 1080Ti on Windows 10. I’ve been mining grin29 just fine with bminer. I’m trying to mine grin31, as it seems that is where I should be. F2pool posts their stratum (grin31.f2pool.com:13654), which I’ve tried to incorporate into bminer. I am mining, but don’t think cuckaroo29 should still be in the script. Can anyone tell me how to modify so bminer can mine grin31 on a 1080Ti? Thanks in advance. Here is the bat I have now:

@echo OFF
REM Change the following address to your GRIN addr.
SET ADDRESS=bminergrin
SET USERNAME=hashraptor.1080Ti
SET POOL:13654=grin31.f2pool.com
SET SCHEME=cuckaroo29
SET PWD=foo

Bminer is still only c29. The fastest for c31 still is the original grin-miner.

1 Like