Very new here. Hi. And help

I just started mining Grin. I am using Grin++ wallet and 2miners.com pool. I don’t know if I messed something up. I’ve been mining other coins for over 2 years and no problem but Grin is different. Okay I was mining and have about 6 Grin on there pool and is stuck there. I talk to there support and they say that my wallet must be working and listening for the incoming transactions. My wallet has been running since 3:44 this morning and no transactions have happen. So how do I get my wallet to listen for transactions?

Nice being here.

2 Likes

Ngrok addresses expire after a few hours. For continual withdrawal from mining pools, you have to forward port 3415 on your router, and then use http://xxx.xxx.xxx.xxx:3415 as your address. Replace the xxx.xxx.xxx.xxx with your public IP, which can be found by going to whatismyip.com

2 Likes

@Angrychicken Welcome to the forums, we’ll definitely get you sorted out.

Are you using Ngrok inside Grin++? If not, what “address” are you putting in for the withdrawal?

1 Like

I took the url it gave me then put it into the generator which gave me a login which I put into my config for my miner. I started mining on 2miners pool. It see my rig. The coin is there but my wallet is not getting anything. I am using a Windows wallet and mining with linux. Here’s what 2miners say to do -

I see. Their site says:

Attention! It is mandatory to always keep your local GRIN wallet online to receive the payouts from the pool. This is the reason why we recommend using the GRIN address generated on one of the supported crypto exchanges.

So:

  1. Keep the wallet open.
  2. Forward port 3415 on your router into your machine that is running the wallet.
  3. Use your public IP as the address. Example: http://xxx.xxx.xxx.xxx:3415. If your public IP changes, you’ll need to update this with 2miners.

Basically, follow David’s steps. Let us know how it goes! :slight_smile:

Okay I tried to set port forward. Where do you put 3415? In External or Internal? And public IP address. The router will not let me add 3415 to the IP address. Says it’s not a valid address. And I put the IP address in the Internal IP Address? And in the Source IP? How do you up date the IP address with 2miners?

I’ve been trying all night to get this to work. I am using a port forwarding tester and 3415 port is not open. Any help please.

You can test the port with a tester such as: https://canyouseeme.org/. Make sure you have the wallet open when you do the test.

For steps to open the port, have you followed the steps of an online tutorial such as https://www.noip.com/support/knowledgebase/general-port-forwarding-guide/? When you log into the router, you need to forward the port to the internal IP of your device. Then, you give the external IP (and port) to the mining pool.

So I have to contact the pools support and give them this info? Why. When you set up your config for mining that should of been all you have to do. I can now see the port.

Nice, now that you can see the port, you just have to provide the withdrawal address to the pool. That’s http://xxx.xxx.xxx.xxx:3415 where the X’s are your public IP address (not starting with 192.168).

Let us know when you get it working! :slight_smile:

I contacted John from support there and ask him to do that. And this is whatt he said

[quote]Are you sure this is your wallet? IP xx.xxx.xxx.xx and this port 3415?
We could try to send to it but you must be sure it is your one…
[/quote]

Yes, search Google for “what is my IP” and tell John what you see. :slight_smile: @david I guess Grin++ uses port 3415 for incoming transactions? I noticed it was 3413 for Wallet713.

I already gave him my external IP and the port. That was a reply to make sure I had the right IP and port. If this doesn’t I’ll leave what coins I mined on that pool and will never mine Grin. It is a PIA! I mined a lot coins and never had this kind of problems.

Maybe it should be renamed to Frown instead! Or PFHCoin (Port Forwarding Hell).

Don’t know why they would make it so hard!

I’ve heard nothing back from support. And no transactions have showed up on my wallet.

More questions. I was looking thru the wallet before I set the port forward. When I click on received it did not have mention anything about port forwarding. Now after I set port forwarding. In red text it mentions about setting port forwarding and setting port to 3415. Why didn’t it mention port forward I set it? I just went back to receive page and that mention of PF is gone.

Hey, good news finally I just got the transaction about 3 minutes ago.

4 Likes

Just sounds like a strange display bug. I’ll make a note of it. Glad your transaction finally went through.

Thank you. Here’s something. Back when I could not get the transaction I stopped mining Grin. But now I started mining Grin again. But problem now is. The pool now doesn’t show my stats so I stopped mining again.