Grin++ wallet 1.2.6 not receiving mining rewards 2miner

hello folks,

I am new to mining and just bought the G1 mini miner to mine Grin, but i am not receiving any rewards in my wallet. Tried below and also suggested by 2miner support

  • to keep the wallet running
  • open port forwarding for ports 3415 and 13415
  • drop any firewall on the machine

I have done all those still no transactions in the wallet. On the 2miner shows 15+ Grin unpaid balance since last night. Interesting every blog i saw it mentioned about the above ports but on my machine running the Grin++ wallet is listening on 3414 and no others . The wallet address shows in green and is running condition in the bottom. Please suggest


I would recommend you to install v1.2.7-beta.2 Release Grin++ Wallet and Node v1.2.7-beta.2 · GrinPlusPlus/GrinPlusPlus · GitHub

You don’t need to do any port forwarding, just to make sure your address is green. Also, you can join the Telegram group for more support

Thanks David i have just done that, now i will wait to see if it gets anything.
Also i will be joining the telegram channel


grinmint supports slatepack withdrawal, should be more straightforward


Have you verified all of the settings are correct?

Also same as below, I would recommend grinmint for future mining.

Unpaid balance means that is not paid yet. If your unpaid balance is not 100% completed you will not receive. Check the total paid section not unpaid balance. You do not need to open ports except if you run grinnode. I also recommend grinmint pool as @satoshocrat mentioned. Here is the tutorial on how to setup your miner. at master · Grinnode-live/ · GitHub

1 Like

I just received the reward in my wallet, so not sure what worked.

Thank you all for your valuable inputs i will for sure look at the Grinmint and its instruction.

thanks again