[solved] Anyone (succesfully) running a RTX 2080 Ti on Linux? Please help!

after getting CPU mining working, i felt confident enough to purchase a RTX 2080, in anticipation of the main-net going live.

I am having a devil of a time trying to get drivers installed for this card. I have tried multiple flavours and versions of Ubuntu , server and desktop.

If anyone has successfully got this card working could they please post a rough outline of what they are using. I don’t need a guide, but a few details would really help.

Things I would like to know:

  • what distro
  • version
  • desktop or server
  • version of drivers used? (from the os repository or from Nvidia web site)
  • version of Cuda toolkit used? (from the os repository or from Nvidia web site)?
  • any tips or tricks that were needed to get it working

Any help is greatly appreciated, thanks

In most cases you should just use the binary

Compiling is not my problem (right now)

i was wondering more about the OS and driver configuration for the system hosting the RTX 2080 TI card.

As far as i can tell support for this new card is not there right out of the box. (on linux systems) or at least any of the ones I have tried so far.

I am wondering if anyone has the card detected and working (drivers and cuda installed) in Linux.

duh RTFM :hot_face:

these RTX cards appear to require a computer with 8 GB minimum system ram

i only had 4gb and the rest of the system was old as dust, pentium dual core 1.8ghz

solution new i7 and new motherboard with integrated intel video for the system video and 16 gb of system ram, this should give me some room to add cards

If you got any info on this please let me know!

Have you successfully start more than one 2080Ti under Ubuntu?

I tried to start three 2080Tis under Ubuntu Server 18.04 (MB: Gigabyte Z370P D3, 8 Gb RAM, CPU: Pentium Gold G5400). After system updating and installing the driver (nvidia-driver-410, tried 415 either) nvidia-smi shows only one GPU which can mine Grin without any issues), other 2 GPUs are displayed only with ‘lspci’ command.

I am trying to install Win7 now to ensure that this is not a MB issue. All GPUs are connected to MB via 1x-16x PCIE risers.

Any help is welcome.

I fully mined with 4x Nvidia 2080 TI FE. I9 and 64Gbs of memory + Ubuntu.

I have more humble setup and now I finally put it to work. :blush:

I followed the instructions at the bottom of this page, titled as “How to Set OS for Mining?”
Option “Above 4G Decoding” is disabled in my case.