iPollo G1-Mini Software/Firmware

Anyone have access to the software/firmware for the G1-Mini? I have a mini that decided it didn’t want to hash anymore and I’m out of ideas other than reflashing what might be corrupted data.

I’ve tried a reset, but I believe that only clears your configuration.

I’ve contacted iPollo, but they don’t seem interested in responding.

The iPollo support scares me more and more

1 Like

Maybe iPollo can make the firmware public on Github. Not sure if they are willing though, it might reveal to much about the miner which could be used by the competition.

@gary You appear to have a short communication channel with iPollo. Do you know if the firmware is avaialble or which communication channel best works to get in contact with iPollo (e.g. they are not active much on the Grin forum)?


I tried to get in touch with iPollo via forum private message and email because I was interested in buying the g1-mini, unfortunately I never got a response. My wild guess is they put themselves in some kind of stasis and will wake up 50 years from here to enjoy a healthy grin price. Maybe then you will get a reply from iPollo


Try this

Same for me. No reply until now. I guess they wont release another sale batch of the G1 Miner.

I would try to call for a iPollo support here.

Dear everyone,
If you need firmware, please send your request to Support@ipollo.com. Our After-sale Service Department will send the firmware to you by email.


Thank you. I just sent an email.

1 Like

What are you saying? This page does allow me to flash new firmware, if I have the firmware image, which we don’t and it’s not on their website, that’s the problem.

This is only saving your configuration files , the “operating” system which is based on OpenWRT is not downloaded with this step.

We (grinnode.live`) are working on publishing a thread here on the forum with everything we have learned and possible make the firmware publicly (not sure if we legally are allowed) to do so.

Also we disassembled one asic and will share the pictures


Interested to see the pictures when you post them. Having 2 of 6 units not hash out of the box (and a third that hashes at half rate), I’m hoping firmware flashes are all they need, but if not, hoping that it may be as simple as a loose cable or something else that could be discovered as an easy fix with your post.