How to set up grinmint payout?

I tried setting up payout, I put the IP of my VPS with following port number on the grinmint guide but it says password is wrong

so how do i correctly set up grintmint for payout?

do i have to open a port? if so how?

Did you read and follow this:

Yes I did, but my question is I am using Digitalocean for mining so would I have to use the IP on digitalocean that I’m mining with?

that is two different thing, you just need to start another grin instance, not grin miner wallet on your vps.

Grin instance is to receive the payout, if you can’t figure it out. please just use exchange.

I got both running on same instance, I just want to know if I would need to put MY IP ADDRESS or the INSTANCE IP ADDRESS?

Nevermind was able to solve the issue.

Hey !

I’ve got a similar noob problem, as for the payout.

I followed this guide, mentionned above :

Node is running, wallet listener started.

I’ve been mining on Grinpool with a computer connected through a VPN.

I’ve requested an email payout, and it wouldn’t send any email with the tx file.

So I’ve tried the HTTP payout method, and here comes the question : The IP address you enter in your settings has to be your local address behind your router, your public address, or the VPN address I’ve been mining through ?

It has to be the IP address your grin is connected to so yes, the VPN Address. you will need to also open port 3415.

Still doesn’t work.

Here is what I tried so far :slight_smile:

  • Open 33415 port on my router [for a reason, it won’t allow me to open ports below 32768]

  • Configure the ./grin/main/grin-wallet.toml to listen to the 33415 port

  • Run the node

  • Start the wallet listener

  • Configure my Grinmint pool settings to :

      => http://my_VPN_public_address:33415
      => Request HTTP payment
      =====> Doesn't work
      => http://my_router_public_address_without_VPN:33415
      => Request HTTP payment
      =====> Doesn't work
  • I’ve given a shot at the email payout solution, but never received any email with the TX file.

I’m a bit clueless, as it is now…

[Edit] It does work now. I’ve deactivated the VPN, and pointed the HTTP request to the router public address, which is a bit annoying, and defeats the very purpose of the VON, but we’ll see that later on… :slight_smile:

The problem was that the router wasn’t properly redirecting my newly opened port.