Grin wallet address

Hey guys, so I am running a grin node and a grin wallet on my local machine, do you guys know how to check the public address/private key for the wallet? I checked the grin-wallet.toml, and the seed file but found nothing, also I have zero balance on my wallet so I cannot generate the transaction file to see the detail in it. Any help would be greatly appreciated.


@kaichen0901 Hey, so I’m running a node and grin wallet as well. What I did was I run an ifconfig to get my local or private IP. Then go to your router and add a port forward for your private IP and port 3415 (the port the wallet listens on). Then go to and it will show you your public IP. Here you can also put in port 3415 and it will tell you if you did your port forward right.

Also you will need to run your wallet listener with a -e or else change the wallet.toml listening ip to

That’s it. I’ve been able to receive http payments from my Grinmint account. Additionally you will need to set your IP on your Grinmint account under your settings tab. This will be your public IP:3415 On the settings tab the instructions show a private IP as the example and I thought this was misleading. Anyhow hope this helps.

1 Like

Since I’m running grin in an Ubuntu virtual machine with VirtualBox in Windows 10, I believe I’m having trouble with the port forwarding due to Windows Firewall:

How do I get port 3415 opened in Windows Firewall? I added a new inbound rule in the advanced firewall settings. I used my Windows PC’s Private IP address in my modem port forwarding configuration (instead of the Private IP of the Ubuntu machine) just to test out whether or not I’m able to get the port open without the added complexity of VirtualBox and the Ubuntu VM. I tried adding the rule 2 ways:

1.) adding a rule for port forwarding
2.) adding a rule for an app (Chrome since I’m checking in Chrome Browser, then open 3415 within the preferences of the new Chrome rule)

Neither directly opening the port or opening it for Chrome seems to change my results at

Not sure where I’m going wrong.

1 Like

@UeliSteck I’m doing the same thing as you on Win 10 and running an virtual Ubuntu machine with Hyper V manager. On the port forward rule on my router I use the virtual Ubuntu machines private IP and port 3415.

When checking if the port is open from the outside with a service like Canyouseeme you have to use your physical PC’s public IP to check and not the private of the VM. I haven’t had to set any Win 10 firewall rules.

This works for me with Grinmint mining pool withdraws but I have been unsuccessful with withdraws from an exchange like If anyone has had success with withdraws from there to a wallet please let me know.

On a separate note I didn’t have much luck with Virtual Box when I first tried, so I switched to Hyper V.

1 Like

Well see, I’ve determined that something must be messing this up besides the VM or Ubuntu. It’s not that because when I use my Windows 10 machine’s private IP address for the port forwarding settings in my modem firmware, it still doesn’t work. Like I can’t get the port forwarding to work with Windows, so the problem must be either Windows, my modem, or my ISP.

1 Like

Ok I see what your saying. Well at the risk of sounding dumb are you getting into your modem or your router? I have two separate devices, my modem provided by my ISP (I don’t get into this) and my router which I bought and set the settings and password.

If it is your Win 10 firewall then it sounded like you set those inbound exception properly to allow traffic through.

1 Like

I figured it out. After my initial failure in getting a port scanner to show 3415 as being open, I was no longer running the external grin listener while performing subsequent port scans. My problem was that no service on my machine, whether in Windows or Ubuntu VM was actually listening on port 3415. So my port 3415 was open all along (once I figured out the necessary steps anyway) but I wasn’t getting a positive result from the port scanners because they were timing out since I had no service listening. So with the grin external listener command running, I was able to get a positive result on the port scanner. With this newfound confidence, I was able to successfully withdraw my first grin from an exchange!

Thanks to TheHelper55464 from this TechSupportForum thread for the suggestion of having a service actively listening on the port while doing the port scan:

1 Like

@UeliSteck Great news. If you don’t mind me asking what exchange did you withdraw from because I’m having no luck withdrawing from Bitforex.

1 Like

I can tell you works for withdrawals, but is sketchy in terms of Uptime and page load time. God, the page loads are slow. CoinGecko said they had the highest Grin volume, but who knows if that’s true. They have 0% fee maker trades, and I suppose reasonable taker fees. There was a 0.3 grin withdrawal fee, not sure how much was miner fee and how much was exchange fee.

1 Like