Withdrawing from Poloniex to grin-wallet

Poloniex only support URL transactions and I need help creating a reachable address on my wallet so I can move some grin off the exchange. I am running a synced grin node and grin-wallet on the one machine running Ubuntu 20.1. I have opened port 3414 for grin.
If my wallet is listening via TOR, should Poloniex’s HTTP send reach it? If yes, I’d like to try it. I will need to set up TOR correctly however. Please point me in the right direction?

If listening via TOR won’t work for Poloniex, what temporary changes to I need to make to meet their needs for this transaction? I have already tried opening port 3415 for “grin-wallet” but it is not working. Should 3415 be opened for “grin”? (port 3414 is open for grin, no problem, but I thought 3415 was specifically for the wallet?) I’m guessing my grin-wallet.toml file needs editing before opening port 3415, but I haven’t found what those edits should be. So this option looks more complicated but I should be able to get it working if someone can tell me the right steps to take.

Thanks in advance!

1 Like

grin-wallet listen will listen both via Tor (if you have it installed and on PATH) and http. Opening port 3415 should suffice, no need to make any changes to grin-wallet.toml, and you’ll have to provide them with your ip:3415 address, not the grin1... one. Tor won’t won’t help here as they haven’t implemented it yet.

Check connectivity to your port while actively listening. If it says your port is open, you’re golden. I’m not sure about opening it for different programs (wouldn’t that be just local?).

1 Like

Thanks! You set me on the right track. So I have been able to open port 3415 and grin-wallet is actively listening. In my router, I had to add an entry in the “Virtual server” table for port 3415 and include the internal IP address. I also had to edit the grin-wallet.toml file. In the line, api-listen-interface also put the internal IP address, matching the IP entry in the router’s Virtual server table.

What threw me was that port 3414 was opened in “Port triggering” on the router, but I just couldn’t get 3415 to open that way. I’m sure there’s a reason.
Next I’ll do a test transaction but it’s looking good at this stage.

Just confirming grins were received successfully :slightly_smiling_face: