Poloniex withdrawal problems

Hi, I tried to withdraw my grins to my wallet with the help of grin documentation and listening wallet. I also tried hedwig and niffler wallet. Every withdrawal ended up with an error.

Fortunately, my grins aren’t lost. They will be refunded. However, I can’t withdraw from the exchange. They haven’t got another withdrawal option.

Has anyone come across these issues? How to solve them?

I’m on Linux. The transaction was unsuccessful even with my firewall disabled.

It’s hard to say when you don’t give any other details except “it didn’t work” :slight_smile:

Generally speaking, http(s) transactions are problematic and will be replaced in the next hardfork. But they do work.

Thank you for replying.

I have changed my toml file according to the documentation (basically allowing wallet to listen on I start my grin node and then grin wallet with listen command.
In Poloniex, I set the receiver’s address as http://<ip>. I also tried http://<ip>:3415. Both failed. The latter is imo wrong, because writing http:// already implies port 80.

Thank you for your help again.

EDIT: Withdrawal fails, coins won’t even leave Poloniex. It’s really weird.

What documentation are you using that told you to change the toml file?

This is the documentation that Poloniex is referring me to:

Outdated mate. Revert all the changes to the toml file and use the new documentation https://docs.grin.mw/

Let me know if you have issues.

Also, if you feel like helping future users, contact Poloniex and ask them to change the link.

I would then argue that the new documentation is not complete. It doesn’t contain sending coins via http and via file.
TradeOgre is doing transactions via JSON file! Because of that “outdated” documentation I was able to accept coins from TradeOgre instead of having my coins stuck.

It was a purposeful decision not to include http and file transactions, as they become useless in 3 months and we don’t have some college intern to rewrite everything. But yes, you’re right, I forgot about it.

By the way I’m not sure how come Grin++ and Niffler both didn’t work. Sounds very odd, maybe you could specify more.

It wasn’t Grin++, it was the basic wallet.

As I said, I tried to withdraw with hedwig to my Niffler wallet, but the withdrawal didn’t come through, which is weird.

Ah i read your original post wrong.

Don’t know much about hedwig and related issues.

But know that if in the near future you wish to withdraw again using http, I suggest Grin++, it seems to work more often. Just make sure the delete everything NIffler related first.

I have another problem. Grin++ needs to connect to my local node? Niffler couldn’t connect to my local node, so I used remote. Now it looks like Grin++ can’t connect to my local node either and can’t use remote.

Grin++ says: STATUS: Waiting for Peers

EDIT: Ok, now my Grin++ is connected to remote peers. However, I’d still like to use my local node. But I’ll manage for now.

Grin++ is it self is a full node (a different implementation of it). You shouldn’t have a “regular” local node with it, nor connect it to a remote node.

1 Like

So I tried the Grin++ http address and the withdrawal still resulted in error. This is very unfortunate.

The address needs to be green when you use it.

It’s a problem on poloniex, had it since 3 weeks ago, I guess they don’t bother fixing it, just like Bittrex.

Grin has withdrawal problems for like a year (more?), this is a real shame, it’s currently the most basic use of it .


I thought so. Thank you for confirming.

As I said, their support is really helpful in refunding the stuck coins, but they don’t bother fixing it, yeah.