Help me to help you support Grin!

@davidtavarez

Hi.
I see that there were about 10 nodes deployed in Amsterdam, yet Grinnode.live currently only shows 3. what could cause this? is that a network issue or a host issue ?

It is not the same code. What you see in Grinnode.live is a count of total inbound and outbound Grin-Nodes connections.

If you want to see a count of all of the nodes you should go here https://nodes.grincc.mw/

3 Likes

I was going to ask the same question :smiley:

Thanks for the info David!

If you are using Grin++ and want to use the nodes, please, find server_config.json file and replace the content with this:

{
	"P2P" : 
	{
		"MAX_PEERS" : 60,
		"MIN_PEERS" : 8,
		"PREFERRED_PEERS" : 
		[
			"188.68.36.183",
			"188.68.49.23",
			"192.3.153.60",
			"217.160.242.228",
			"217.160.66.118",
			"212.227.210.43",
			"93.90.194.26",
			"82.165.107.169",
			"45.156.22.227",
			"45.156.21.8",
			"194.116.216.213",
			"89.58.0.69",
			"23.94.220.240",
			"107.175.221.215",
			"23.94.105.34",
			"107.174.93.181",
			"23.94.120.32",
			"75.127.9.248",
			"107.174.93.165",
			"107.174.172.157",
			"23.94.220.239",
			"75.127.9.247",
			"107.174.176.161",
			"23.94.216.223",
			"23.94.220.238",
			"107.174.93.160",
			"192.3.153.163",
			"66.42.124.255",
			"192.3.62.235",
			"192.3.254.163",
			"23.94.120.31",
			"23.94.101.24",
			"23.94.107.192",
			"23.94.105.33",
			"23.94.120.30",
			"107.174.63.210",
			"149.28.160.219"
		]
	},
	"WALLET" : 
	{
		"DATABASE" : "SQLITE",
		"MIN_CONFIRMATIONS" : 8
	}
}
4 Likes

If you are using grin and want to use the nodes, please, find grin-server.toml file, uncomment peers_preferred and replace the content with this:

peers_preferred = ["188.68.36.183", "188.68.49.23", "192.3.153.60", "217.160.242.228", "217.160.66.118", "212.227.210.43", "93.90.194.26", "82.165.107.169", "45.156.22.227", "45.156.21.8", "194.116.216.213", "89.58.0.69", "23.94.220.240", "107.175.221.215", "23.94.105.34", "107.174.93.181", "23.94.120.32", "75.127.9.248", "107.174.93.165", "107.174.172.157", "23.94.220.239", "75.127.9.247", "107.174.176.161", "23.94.216.223", "23.94.220.238", "107.174.93.160", "192.3.153.163", "66.42.124.255", "192.3.62.235", "192.3.254.163", "23.94.120.31", "23.94.101.24", "23.94.107.192", "23.94.105.33", "23.94.120.30", "107.174.63.210", "149.28.160.219"]
2 Likes

Opening Grin++ after 8 days, port is open, 12 :arrow_up: / 2 :arrow_down:, list of nodes added , 12K blocks behind, took an hour of syncing.
Not great.

Nice I’m syncing my grin “core” node now, And it is going super slow with low peers. I am going to try this now

If you are in Europe, use this list for Grin++:

{
   "P2P":{
      "MAX_PEERS":60,
      "MIN_PEERS":8,
      "PREFERRED_PEERS":[
         "188.68.36.183",
         "188.68.49.23",
         "217.160.242.228",
         "217.160.66.118",
         "212.227.210.43",
         "93.90.194.26",
         "82.165.107.169",
         "89.58.0.69",
         "23.94.220.240",
         "23.94.105.34",
         "23.94.120.32",
         "23.94.220.239",
         "23.94.216.223",
         "23.94.220.238",
         "23.94.120.31",
         "23.94.101.24",
         "23.94.107.192",
         "23.94.105.33",
         "23.94.120.30"
      ]
   },
   "WALLET":{
      "DATABASE":"SQLITE",
      "MIN_CONFIRMATIONS":8
   }
}

and for grin-wallet in Europe:

peers_preferred = ["188.68.36.183","188.68.49.23","217.160.242.228","217.160.66.118","212.227.210.43","93.90.194.26","82.165.107.169","89.58.0.69","23.94.220.240","23.94.105.34","23.94.120.32","23.94.220.239","23.94.216.223","23.94.220.238","23.94.120.31","23.94.101.24","23.94.107.192","23.94.105.33","23.94.120.30"]
1 Like

If you are in America, for Grin++ use this list:

{
   "P2P":{
      "MAX_PEERS":60,
      "MIN_PEERS":8,
      "PREFERRED_PEERS":[
         "192.3.153.60",
         "107.175.221.215",
         "192.3.153.163",
         "75.127.9.248",
         "75.127.9.247",
         "107.174.63.210",
         "192.3.254.163",
         "192.3.62.235",
         "66.42.124.255",
         "107.174.93.160",
         "75.127.9.247",
         "107.174.172.157",
         "107.174.93.165"
      ]
   },
   "WALLET":{
      "DATABASE":"SQLITE",
      "MIN_CONFIRMATIONS":8
   }
}

For grin-wallet in America:

peers_preferred = ["192.3.153.60","107.175.221.215","192.3.153.163","75.127.9.248","75.127.9.247","107.174.63.210","192.3.254.163","192.3.62.235","66.42.124.255","107.174.93.160","75.127.9.247","107.174.172.157","107.174.93.165"]
1 Like

For those Grin++ users in Russia and Ukraine:

{
   "P2P":{
      "MAX_PEERS":60,
      "MIN_PEERS":8,
      "PREFERRED_PEERS":[
         "45.156.22.227",
         "45.156.21.8",
         "194.116.216.213"
      ]
   },
   "WALLET":{
      "DATABASE":"SQLITE",
      "MIN_CONFIRMATIONS":8
   }
}

And for grin-wallet in Russia and Ukraine:

peers_preferred = ["45.156.22.227","45.156.21.8","194.116.216.213"]

Yeah… so why is it still so slow?

I do not know, maybe peers were banned for some reason. What you can do is this:

  1. Close Grin++
  2. Delete the content of the peers folder (~/.GrinPP/MAINNET/NODE/DB/PEERS)
  3. Make sure you are using the Europe list if you are in Europe.
  4. Open Grin++

Preferred peers means that the node will use that list to try to connect to them initially. You can also change the field name to ALLOWED_PEERS so your node will only connected to the peers in the list, but I do not recommend that.

2 Likes

Big help for my most recent sync. Cut the initial download time in half, if not more (due to otherwise slow or unreliable peers.)

I will say for the grin-wallet/node you have to add “:3414” at the end of any preferred IP address, otherwise you will get an error on startup from the toml “cannot parse DNS” (or something like that.)

3 Likes

I’ve mostly been helping by mining but would like to setup a node too.

3 Likes

Also for anyone running the reference node (not grin++) change your
peer_max_outbound_count AND peer_min_preferred_outbound_count to a higher number in order to have you node look for more peers. This is not always needed but incase your node seems like it wont connect to more than 8 peers try to raise this. My non mining node connected to 45 peers immediately when adding the local hardcoded preferred peers but the mining node stuck to 8 even with exact same config. Until I raised the peer_min_preferred_outbound_count setting the mining node would only look for ~8 peers even if peer_max_outbound_count was set to 50

4 Likes

I’ll donate $37 of grin if someone fixes the annoying slatepack requirements, or conforms to the slatepack requirements but simplifies it or something.

The guy that wrote the Ledger Live app is awesome, most coins require a 3rd party wallet. Unfortunately, when mining Grin I still have to use Grin++ to collect my payouts to the single online address, then have to approve transactions 50 times on both ends… trying to get slatepacks from one device to the other quickly just to deposit.

If it’s annoying for me, it’s probably impossible for 99% of other crypto investors.

Anyway, thanks for the nodes!

I guess you are talking about mining via GrinMint. Personally I prefer getting paid whenever I want by just copying some slatepacks around, which is the GrinMint style.

You mean 3 actions, that is the maximum you need for payouts.
If you do not like to have any manual actions, just run a wallet all the time and use a pool like https://grin.herominers.com/ they payout automatically over tor, so no manual action needed.

Just to be clear, you should never use a hardware wallet for mining payouts. Just use a hot-wallet, and maybe every quarter or so, transfer to your hardware wallet. Having to many UTXO’s for many mining payouts is something most hardware wallets cannot handle.

Ah gotcha. Yeah 2miners uses the online address. I’ll need to look at the other pools you mentioned, curious if they have easy-to-use solo mining pools like 2miners.

I posted a long response but deleted it haha, it’s not related to the purpose of this thread so I didn’t want to clog it up with Grin utility & ease-of-use concerns. I’m sure the transaction methods available in general have been discussed plenty of times elsewhere.

Thanks again!

About the nodes:
Activating one ($37) closer to my location I’m assuming would speed up my wallet transactions and syncing time? Can I solo mine using it? That way I don’t have to use a solo pool or keep my pc connected 24/7

Wallet transactions should be near instantaneous, at least for me they are. Ofcourse, you still need to wait for a block to mine for confirmation. You can solo mine with a node and wallet in a virtual machine, on a Raspberry Pi, or if you do not like the hassle, you can use EasyGrin:

I have not used this myself, but apparently it is super duper easy to use. Just do not leave to many funds on there just in case.