Grin++ 1.2.2 available now!

A new update is now available: Grin++ 1.2.2

We encourage all users to update their wallets. A lot of fixes were added to this new version, specially regarding of sending and receiving your coins. The UI was upgrade to take advantage of the past HF, now it is simpler and easier to use. Some new features are:

  • The stability of Tor was increased.
  • New Dashboard design.
  • The ability of read the logs directly from the application.
  • A link to the Support Group channel of Grin++ was added.
  • A QR Code for the slatepack address.

Thanks for all the help reporting the issues, you will see the option to upgrade your wallet when you open your wallet. Remember, you can also download Grin++ from our website:

This is how Grin++ looks now:

If you need any help, please join the Support channel: Telegram: Contact @GrinPP



Awesome work!

Feature request:

Either stop capitalizing the account name in top left, or provide an option to toggle this behaviour.

1 Like

I have an addiction capitalizing words :sweat_smile: but yes, I will not capitalize the account name, that should be fixed on the next release; there is still some work to do for the UI, and also some missing translations should be included, but now since the backend is running stable enough I can focus on updating the Android binary.


Hello there, i test the latest version and unfortunately i see the same error “node is not running”. Am I the only only one that get this error?

One user solved the issue this way. First, close your wallet.

Go to this path:

  • On Linux & MacOS: ~/.GrinPP/MAINNET/server_config.json.

Open the file named: server_config.json, if the file probably contain something like this:

Then replace the content of the file with this (in one line):

Save the file and open the Wallet again.


Solved! I installed the latest version 1.2.2 but the node was not connected from the beginning and the .GrinPP folder did not exist. I installed version 1.2.1, configure json, the wallet was upgraded to the latest version and everything works perfectly. I successfully transferred all the grins to the Grin ++ wallet. Thank you :slight_smile:


Solve my headache. My impression is that the Grin++ app is so fragile. So many issues: tor is not started, the LOCK file prevents Node syncing, server_config.json becomes null, each one leads to dead of the APP. It is so annoying. The user experience is so bad.

Please don’t forget that grin ++ is also running a node and we need as much as possible feedback to make it a kick ass app. the challenge is bigger that any other crypto wallet

I’m sorry you have that impression. We’re always asking for feedback and for users to report any issue so we can fix it for everyone; for instance, there is a proper fix on the way for the issue reported by @nirg on this thread.

This is another example of how things goes when a user report an issue. This release includes a good improvement on how Grin++ is managing Tor, as I said in my initial post.

Again, please join Telegram: Contact @GrinPP and report any issue you’re facing so we can fix it for everyone.


One more issue here.

I have installed 1.2.2. Node is fully synced and the status becomes green showing running. However, when I try to restore my wallet, the button is bright yellow. I click it. Nothing happens. I then quit the Grin++. I check the folder ~/.GrinPP/MAINNET/WALLET and there is indeed a folder with my username. But when I restart Grin++ and click the username button, the waiting sign is spinning forever. The error log says

[01/20/21 17:44:26.857+08:00] [debug] [THREAD:0x70000dd70000] OpenWallet(37) - wallet.db already open for user: xxx


[01/20/21 17:48:11.538+08:00] [error] [THREAD:0x70000390d000] Execute(91) - Failed to execute command: update metadata set next_tx_id=0, refresh_block_height=0, restore_leaf_index=4558715 where id=1;. Error: attempt to write a readonly database
[01/20/21 17:48:11.549+08:00] [error] [THREAD:0x70000390d000] CheckForOutputs(132) - Exception thrown: Execute - Failed to execute command.
[01/20/21 17:48:11.550+08:00] [error] [THREAD:0x70000390d000] Login(187) - Error (CheckForOutputs: Execute - Failed to execute command.) while attempting to login as: xxx
[01/20/21 17:48:11.553+08:00] [error] [THREAD:0x70000390d000] Handle(145) - Exception occurred: CheckForOutputs: Execute - Failed to execute command.

v1.2.3 is now out and it should fix the reported issues so far.


I won’t agree with you that grin ++ is fragile because I’ve been using it for quite some time and it was the first time, speaking personally, that a small problem occurred. I can also tell you for sure that I use it in an isolated, offline environment (vault virtual machine) except when I make transactions, maintaining a network connection as long as the transaction takes and then back offline. Upgrades are always on time and I’ve never had trouble delaying or losing Grin. I just tested the latest version v.1.2.3 from scratch and so far no error has occurred.