Connecting Ironbelly to own node

I’m having trouble getting Ironbelly to connect to my own node.

So far I have:

Set API address to “” in grin-server.toml

Opened 3413 TCP in ufw

Created an A record

Set API secret in Ironbelly from basic auth secret

Can anyone think of anything else to do?

Node is not on my network so this isn’t a hairpin NAT issue

I’m unsure of what formats the Ironbelly URL accepts, does work?

Is https with valid cert required?

Solved: I was using ~/.grin/main/.api_secret but you must use ~/.grin/main/.foreign_api_secret

So far I have tested that http://[ipv4 address]:3413 and both work. I haven’t tested dropping the port or protocol from the url so I don’t know if that works too. Sometimes it seems like you have to restart the app to really test any new entry in the grin node setting.

For testing purposes you can always use the public and free GRIN-API from

Logging policy: