Coins all gone while sending to

Hello, i tried to send my coins to but i forget to add the Memo number. I canceled the transmission because it was not completed yet but my coins are all gone. Is there a possibility to get my coins back ?

The coins are not gone, but your wallet did not register the cancel properly. If you use grin-wallet, you can fix this by running
./grin-wallet check-repair --cancel-unconfirmed

Another option is to restore wallet from seed. The transaction that was cancelled will be forgotten, unlocking your coins. Restoring from mnemonic should work for all wallet softwares.

1 Like

i use grin++ wallet. where can i add this command? thank you , sorry i am new to this

I would use the official Telegram group for Grin++ to get support

hey and thank you for your feeback. i restored my wallet with my seed phrase and same username but the amount is still 0 ?!?! any other idea? thank you very much

I hope you did make a backup or left your old account on Grin++! The user name has nothing to do with Grin, it is just there for your convenience.

If after restoring from seed the funds are not there, make sure your node is fully synced and is connected to peers. If after fully syncing your wallet still says there are no funds, the only conclusion would be that your transaction did happen and was not cancelled. Please try restoring from seed using a different user name just to make sure Grin++ is not by accident using the old/wrong wallet information.

Always keep a backuo of the old wallet, in case you need to prove the transaction did happen.

1 Like

i did a restore with 3 different usernames already but always 0 grin coins inside. The wallet is synced 100% and green.

In that case you need to contact support and provide proof the transaction was made. Make a screenshot and copy all information you can find when you click the transaction in your wallet. E.g. kernel, amount, time etc. Hope they can verify in their wallet the transaction was received using that information.

1 Like answered this one:
In this case please contact the support team of the sending platform and ask them for the txid, the network that was used, and the link to the transaction in the blockchain if possible.
With this we will be able to locate the transaction and check what the problem might be.

Can you try to import wallet to ironbelly wallet with your 24 seed words?
Maybe you couldnt synched.

thx for the tipp. i tried this also but sadly no coins in the wallet :frowning:

I wonder how did you feel when you lost the ownership of your coins, tell it also. Maybe you can post this other social channels, reddit and twitter.
You are not the only one. Somebody will help you i am sure.