Can't withdraw to Grin++

I’m trying to transfer some GRIN from Poloniex to Grin++ wallet. The address section gives an address and then a partially completed url. If I click the url part nothing happens.

Then the Receive section shows that it wants a .tx file but Poloniex does not provide this. Poloniex gives the following when I try to add just the address, “Your GRIN address must be formatted as an HTTP or HTTPS URL”.

How do I get the URL from Grin++? I’ve tried right click but again nothing happens.

UPDATE. I found a page on receiving GRIN https://github.com/mimblewimble/docs/wiki/how-to-use-the-grin-wallet#receiving-grins so I will try this.

Latest Grin Wallet Update here:

https://paouky.github.io/docs/about-grin/transactions/

The HTTPS URL is the green address, that’s the one you use. Just keep your wallet open (and address green) and pray that Poloniex will let you withdraw.

And status of all active exchanges here:

But there is no way to copy it because it has … in the middle and clicking it doesn’t do anything. Surely the … is missing characters which would represent the full address. Unless I’m supposed to put something in there.

No no need to add anything in there, just clicking on the address should copy it.

1 Like

It does! Usually these things say “copied” or something. Thanks.

BTW I already talked to Poloniex who just got their GRIN wallet withdrawals online again.

No problem, I can see the confusion.

Cheers.

1 Like

We used to have a tooltip that said that, but we lost it somewhere along the way. I’ll try to get this added back for the next version.

1 Like

Much appreciated, it’s good to see that you care about the user experience.

How long do transactions take to complete? The wallet says Running but Spendable says 0.00000000. I tried a block explorer but the address did not show up.

You won’t find the address in a block explorer; Grin has no addresses. They are just wallet-to-wallet addresses, i.e. that’s how the wallets “find” each other so they can complete the transaction interactively. They are never in the chain itself.

Once Poloniex sends the transaction it should only take a couple of minutes really. Try to Restart Grin++ and then Resync if it still doesn’t appear.
If your balance is 0 after doing both, the problem is 100% with Poloniex.

I did a resync and restart but when it loaded back up it said Status: Waiting for Peers.
It wasn’t doing this prior to the resync.
I also created a firewall rule to open up port 3414 outgoing tcp+udp for Grin++ application but it didn’t seem to help.

Click on the transaction in Grin++, and get the “kernel commitment.” Search for that on grinscan.net. If it’s not there, the transaction was never finalized.

Will do once it appears thanks.

If there’s not even a transaction listed, then the coins were never sent to you. You need to contact Poloniex.

The problem is that Grin++ is not working at the moment and is stuck on syncing blocks for several hours now since the Resync discussed above. It’s been on 67% for ages now.
syncing stuck