Grin++ Receiving Address Query

Hi all,

I have upgraded to the latest Grin++ (v0.7.2) for windows and I noticed that the receiving address has changed from an ngrok.io address to a localtunnel.me address. With ngrok.io it was always https protocol, but localtunnel.me is displayed as simple http.

Is this truly http or should it be https?

The reason I ask is because all exchange interactions with Hotbit.io to withdraw to my local Grin++ wallet have failed since I upgraded. And Hotbit have repeatedly ignored a direct query as to why the transactions failed, so I have absolutely no idea why this is occuring. They have been very difficult to deal with.

Should I use https protocol instead with my ephemeral withdrawal address?

Has anyone else experienced these issues as well?

Sorry to hear that. A few things:

  1. The latest is now v0.7.3
  2. Yes, I switched to localtunnel because I was unable to ship ngrok on mac, though I haven’t been real impressed by localtunnel. For starters, their cert is expired, or at least was a week ago, so I had to default to http.
  3. If your tor is working, I have a better option for you. Use http://<your_tor_address>.grinplusplus.com
    This will actually pass it along via tor, which appears to be less fragile. Also, I’ll also be supporting https as soon as I figure out how :laughing:
1 Like

Hi @david,

Great I have just upgraded to v0.7.3.

As for localtunnel.me, It seems that KuCoin won’t allow that domain to be used, which might be a problem once their hard fork changes are completed.

As for TOR, I never knew how to use it, but now that you have provided those instructions I think that will be the best option as that address appears to be static and I can just send the grin straight from the mining pool to my wallet, without the need for the exchange at all. This is a far simpler solution. Thank you for providing those details.

So, assuming the TOR address gets generated in Grin++, is that all I need to do to allow the funds to find my wallet? Or are there any other Tor-related clients that need to be installed?.

What do you mean Kucoin won’t allow localtunnel? Did they censor that domain now too? They did the same with ngrok before. They’re an absolute shit exchange that insists on making life difficult for their users.

No need to do anything special with tor. Just make sure the address is generated fine and stay logged in.

1 Like

It seems they have indeed, but this is just my experience. Probably need some others to corroborate. I tried adding a withdrawal address and it simply did not l allow me to save an ‘Invalid address’.

With that said, they have no issue with the TOR address. I have already shifted my mining pool address over to TOR, so hoping that all goes well once the next payout occurs.

Thanks for Grin++ - it is definitely something I use each day and love the fact that a full node is built-in.

1 Like

i never had any issues withdrawing from poloniex to Grin++ using ngrok (on older grin+±version) or localtunnel (current version). Looks like KuCoin is making it as hard as possible to withdraw your Grin.

1 Like

It seems like Hotbit makes it very difficult as well. I am starting to have second thoughts about using Chinese exchanges. since the chinese essentially dominate the crypto market, perhaps they are trying to maintain that dominance in every way they can? Sounds like a conspiracy theory, but…

1 Like

Hedwig, which operates exactly the same way as ngrok and localtunnel (it actually is just an instance of localtunnel-server), has never been banned by Kucoin. It’s operated by a Chinese developer…

P.S. I’m mostly kidding. That’s probably not why they banned ngrok and localtunnel, yet not Hedwig. But still, Kucoin is trash, and everyone should avoid them.

1 Like

Somehow I am not surprised. :roll_eyes:

I have v0.7,4 and cant’t get a http(s) address and withdraw my Grin from the exchnage.
Tried the “http://<your_tor_address>.grinplusplus.com” and did not work

I have v0.7.4 as well and received funds via Tor without issue a few hours ago.

When you click the Receive button in Grin++ does it show you a TOR address? If not you will need to go into settings and tick Tor

It shows the Tor address and I have it.
How can that be turned to an HTTP address that works

Perhaps check the following:

  1. Verify there are no leading or trailing spaces in the address provided to the exchange
  2. Verify there are no leading or trailing spaces in the tor address portion of that address
  3. Check with the exchange and confirm that they accept the address as being valid - some exchanges are a bit funny with some wallet addresses when it comes to GRIN.
1 Like

Thanks
Everything was working with the previous versions of the Grin++ and why we are having this issue?
Can we not just simply have the HTTP address?

Oh, OK, I was unaware you previously had it working fine.

I suspect @david might be able to shed some light on this?

Thank you for the insight and help

What’s your tor address?

Has the exchange shown the withdrawal as successful or do they show it failed?

If it shows failed ask them if they can tell you why it failed - this will help in the troubleshooting. Not all exchanges will do this, but it is worth a shot.

je5x247fsixuabu3f56cb5poydaybbzn2dxnof2eqdwoyayczjqtwqyd

It shows it has failed