Troubleshooting: Grin does not run (Ubuntu bootable USB)

I have created an Ubuntu bootable USB drive, since I run Windows 10 normally. I just wanted to see if I could get a grin node spun up on a bootable USB to test the waters.

Well I followed all the steps in the guide (, but when I get to the final step of just running grin, nothing happens.

I’m not really sure where I went wrong, but I am not seeing any Terminal out put after these 2 commands:
echo export ‘PATH=~/grin:$PATH’ >> ~/.bashrc
source ~/.bashrc

The tutorials are a little lacking in that they don’t give you the expected output or response that you should get in Terminal after issuing a command. Nor is there much troubleshooting advice that I can find, which is why I came here. Sorry if someone else has already posted a similar issue.

I’m really excited about GRIN, but I’m a Linux noob. I’m really just clueless about command line and stuff. Plz HALP!

The above two lines are all that you needed to share. Did you install a 32-bit distribution of Ubuntu (ie. desktop-i386) instead of a 64-bit distribution (ie. desktop-amd64) ?

No I was using 64 bit. I have since tried this on a Linux VM, and I had a lot more success. Got a node synced and wallet running. Next step to test out mining.

I think the takeaway from my experience is that Grin maybe doesn’t work with Bootable USB drives? Maybe I did something wrong, but it does make a whole lot more sense to use a Linux VM or dedicated Linux box.

bro, u can go to shop buy a 32gb usb for 15$ max that reads and writes good. shove that in USB 2 up in dat PC there with the live aswell

  • install to the 32GB and when install is finished and you have restarted and removed the live boot and set ur boot priority in bios
  • then u can build the grin wallet using the first half of this guide here - >>Grin v1.0 Step by Step Miner Guide on Ubuntu [English version]
  • restart that there PC of yours after you done the build and got up to the grin-miner part of the above link.
    -type grin and u got there that them grin node geeeee.
    -go to for guides on running wallet and node.
1 Like

cant build on live usb i dont think. dun mak sense

Ubuntu is likely a weird case; they play nice with ufie and are trying to be professional while not being good at it for example.

I wouldn’t make that broad claim, unless your using a more linuxy linux distro. And even then there are full blown usb systems like puppy that are made to run as if the usb was a normal hard drive and not the “see if the wifi works, sorta safe mode that can install” thing most do. And then gentoo and arch exist and all bets are off.

Ubuntu is not known for their stable, well written software,(unity was dog shit and ubuntu phones and tvs died before I ever saw them) I would blame that, before I assume something is wrong with this software.

They try to be apple and are not great at it.

And if ur trying to mine through VM good luck. Lol need to virtualise ur gpus aswell

Well I was only trying to mine on a Bootable USB / VM as a test of my own abilities to get it working, not as a long term solution. I had been wondering about how the VM would handle high graphics card load. What if I just want to CPU mine within the Linux VM as a test? Does CPU mining not “just work” or do I have to virtualize the CPU? Because it seems like that is the purpose of the VM and what it is already doing…

I guess I’ll have to spin up a dedicated Linux box to GPU mine.

OK now I’m having another issue that I will probably make another post about, but figured I’d post in these comments as well…

I am trying to receive some grin from an exchange where I purchased it. My understanding is that once I run grin wallet -e listen I should be able to receive transactions by using a link of the format “http://My_Public_IP_Address:3415” as the withdrawal address on the exchange.

However, I have not been able to get port 3415 open, using to check…

I have added port forwarding for port range 3415-3415, Inbound and Local, to my modem’s firmware options, entering the first “inet” address I get from running ifconfig into the Private IP Address field in the port forwarding options. So this is the Private IP address of the VirtualBox Ubuntu virtual machine within which I am running the grin wallet / node, and it has a format like 192.168.x.x.

I have the VirtualBox Ubuntu machine in Bridge Adapter mode.

I am running this Ubuntu machine on a Windows 10 installation. I tried turning on port forwarding for 3415 at the Private IP Address of my Windows 10 machine (by replacing the Private IP Address of the Ubuntu machine in the port forwarding settings of my modem) to see if I could get it to register on CanYouSeeMe, and it did not work!

So now I am thinking my windows settings are to blame. Is there something I need to change in Windows Firewall or in the advanced options? Like enabling “Allow an App Through the Firewall” or port 3415 specifically for certain apps in Windows Defender Firewall Advanced Settings?

I’m at a loss for how to get this port opened up completely. It’s like there are several gates that must be opened: Modem port forwarding, Windows Firewall?, VM Bridge Adapter, am I missing anything?

I don’t want to make either my Windows machine or my Ubuntu VM vulnerable to security issues due to improperly setting up the port forwarding.

Any suggestions?!

@UeliSteck Hi, I’ve had exactly the same issue with trying to open port 3415. Instead I just used port 3413 for a html payout, which works just fine. So you don’t have to use 3415, try to find a port that is open to your machine/router and just use that to listen & receive Grin.
Alternatively route/forward the remote port XXXX that works to 3515 local.

I figured it out. After my initial failure in getting a port scanner to show 3415 as being open, I was no longer running the external grin listener while performing subsequent port scans. My problem was that no service on my machine, whether in Windows or Ubuntu VM was actually listening on port 3415. So my port 3415 was open all along (once I figured out the necessary steps anyway) but I wasn’t getting a positive result from the port scanners because they were timing out since I had no service listening. So with the grin external listener command running, I was able to get a positive result on the port scanner. With this newfound confidence, I was able to successfully withdraw my first grin from an exchange!

Thanks to TheHelper55464 from this TechSupportForum thread for the suggestion of having a service actively listening on the port while doing the port scan:

1 Like