Testing ocl_cuckatoo plugin

The computer I intend to mine grin with is an AMD Ryzen 7 with a RX580 AMD (8GB) card on Ubuntu 18.04. I know that cuda is better supported but I dont have an NVIDIA card avail at the moment. I’m testing the various options I have.

I noticed the grin-miner repo got opencl support and decided to give it a whirl.

  • I installed opencl (via; sudo apt install ocl-icd-opencl-dev)
  • I ran ./install_ocl_plugins.sh to install the plugins (no error)

grin-miner starts and successfully connects to stratum before it receives the following error;

thread ‘<unnamed>’ panicked at ‘Platform::list: Error retrieving platform list: Unable to get platform id list after 10 seconds of waiting.’, libcore/result.rs:1009:5

my config settings are;

plugin_name = “ocl_cuckatoo”
platform = 1
device = 0
edge_bits = 31

Does anybody have any ideas? Im guessing by the error the system cant actually communicate with my opencl drivers although i did install the latest drivers from amd. I ran glmark2 and received like a 5850 scores or something.

FWIW, CPU mining (cuckaroo_cpu_avx2_29) yield about 0.25 gps

plugin_name = “cuckaroo_cpu_avx2_29”
nthreads = 8

Could you post output of clinfo command?
Cuckaroo29 for AMD is around the corner btw.

I have the same error with AMD Radeon R7 M360 on Xubuntu 18.04. clinfo returns “Number of platforms 0”