Ining with Intel HD Graphics 5500 (Broadwell GT2)

Hi everyone,

I am trying to mine Grin with a spare laptop I have hanging around. It has 16gb of ram but unfortunately no AMD / NVIDIA. I did a clean installation of Ubuntu and followed all the instructions successfully setting up a node, creating my wallet etc.

When I try to use the Grin miner however, it connects to the Grin Server but does not recognize a Mining Device. Any ideas?

For the record, I tried this using “cuckaroo_cpu_avx2_29” plugin as the default which says is the fastest CPU algo, as well as various of the other CPU options like “ocl_cuckatoo”.

Any ideas of what would be the most appropriate configuration and why it does not recognize any mining device?

Many thanks,

Solved - the issue wasn’t with the settings, it was with not having run this:
./grin server config and setting enable_stratum_server = true .

Up and running with this graphics card so hopefully others can do!

What drivers you use I cannot run it