Issue syncing grin node 0.4.2

Hi, I’m having issues syncing a grin node on google cloud following the instructions:

Connecting peers remains at zero and it is stuck in running state, any ideas or anyone else experiencing this issue?

I have the same issue on my local machine with the release “grin-v0.4.2-464718698-osx.tgz”.
Also tried to change the seeding type to “List” and hardcoded some seeds. But didn’t help.

From the log:
20181228 12:57:08.288 DEBUG grin_servers::grin::seed - monitor_peers: on, 0 connected (0 most_work). all 0 = 0 healthy + 0 banned + 0 defunct
20181228 12:57:08.288 DEBUG grin_servers::grin::seed - monitor_peers: no preferred peers
20181228 12:57:08.288 DEBUG grin_servers::grin::seed - monitor_peers: no dandelion relay updating
20181228 12:57:08.288 DEBUG grin_p2p::peers - Could not update dandelion relay
20181228 12:57:13.194 WARN grin_servers::grin::sync::syncer - sync: no peers available, disabling sync

You can try setting

seeding_type = “DNSSeed”

peers_preferred = [“”, “”, “”, “”, “”, “”, “”, “”, “”, “”, “”, “”, “”, “”, “”, “”, “”, “”]

in your grin-server.toml

Thank you, but it still won’t connect. Here is what I did (maybe you spot my mistake):

  1. Download the latest pre-compiled file from (osx)

  2. Edit the grin-server.toml file (Location: [user home]/.grin) and add the “peers_preferred”.

  3. Start the node with RUST_BACKTRACE=1 ./grin

Then it switches to “waiting for peers” and after 40-60s to “Running” but nothing happens.
Connected to peers stays at 0.

@0xenophilius Im still getting the same issue; does it align with this bug?

Floonet has been relaunched and the seed servers seems to be downed for a while. Upgrade to 0.5.0 and try again.

1 Like

Thank you @codeb2cc!
That worked!

@codeb2cc @0xenophilius Do I need to rebuild 0.5.0 from source to upgrade from 0.4.2 or is there an easier way?

Never mind figured it out