[Building Grin T4] - stuck at "Waiting for peers"

Problem: Whenever I run grin using ‘grin server run’ command. The ‘current status’ stays stuck on “Waiting for peers” as displayed in the image below.

After building the grin (following this guide: https://github.com/mimblewimble/grin/blob/master/doc/build.md) into my bash Ubuntu 18.04. I’ve never been able to get my instance to sync. The ‘connected peers’ : number also does not exceed 2, and I am stuck on chain height 0.

Looks more like your setup. I saw no problem on > 10 different Ubuntu testnet 4 setups.

The only time I didnt found peers on one host, I fixed it by switching seed type: from “DNSSeed” to list of hardcoded healthy peers (in the grin-server-config file).

Did you read the logs?


I got the same issue and did the following:

  1. cd grin
  2. sudo nano grin-server.toml
  3. scroll to last line: copy paste: run_wallet_listener = true
    ctrl x to close and click y to save.
  4. reboot the server

You’re the same @goldenrule from this thread right? Grin text user interface not displaying when run grin

You resolved that by adding
run_wallet_listener = true
to grin-server.toml?

Strange. Whether or not the wallet listener is running shouldn’t affect the ability of grin to connect to peers. Am I wrong, @antioch ?