Grin node 0.5.1 sync issues

I’m trying to sync a grin node on floonet and it keeps getting hung up on step 1/4 downloading headers.

When I run the log, I see the following series:

20190107 17:33:16.260 DEBUG grin_chain::chain - body_sync: body_head - edc758c1, 0, header_head - 0104492c, 14592, sync_head - 0104492c, 14592
20190107 17:33:16.451 DEBUG grin_chain::chain - body_sync: need a state sync for txhashset. oldest block which is not on local chain: 026ea624 at 1
20190107 17:33:16.451 DEBUG grin_servers::grin::sync::body_sync - body_sync: cannot sync full blocks earlier than horizon. will request txhashset
20190107 17:33:16.461 DEBUG grin_servers::grin::sync::body_sync - body_sync: no pending block request, asking more

Can anyone help me diagnose this problem? Did I miss a step in config?

FYI I’m running Manjaro / Arch Linux (latest version)

Thank you in advance for your help.


This should now start downloading the whole chain state as one big file. Any other occurrence of the word txhashset in your logs? Do you have a slow connection? Status should update once in a while telling you about said download.

So I have the node running now, but the chain height is stuck at 0. When I start the server, I have about 10 peers, but all connections are outbound. The number slowly ticks down to one or two (both of which have a chain height of 0). Is there any reason why I might not be able to connect to peers. I’ve already followed the steps here except I haven’t removed peers directory yet (which I found in chain-data…not sure if that is the one):

Here are the relevant screenshots:

UPDATE: added hard-coded peers according to the post here. Still running into the same issue.

Like many, I want also to install a node.
What’s the recommended version to install now ?
is it fine with v0.5.1 , or too risky ?
It will be on Debian 9.6 64bits 16GB.

PS: Thanks to the devs for all the great work.

It looks like I keep losing the connection with the other nodes as I’m syncing. Looking through the logs, I keep having the following error:

20190108 13:15:52.229 DEBUG grin_p2p::peer - Client connection lost: Connection(Custom { kind: ConnectionAborted, error: StringError(“read_exact”) })

I installed grin v0.5.1 on a Debian 9.6 16GB.
Install seems successfull, and grin --help, grin server help, grin wallet help, returns what expected

But when I run

grin --floonet

just nothing happens
There is even no grin process running ?

What I’m missing ?

Did you adjust any of the settings in the .toml file?

Thanks for the advice.
No I didn’t touch any of those .toml settings (but I’ll have a look).

Here is grin-server.log:

20190110 16:01:17.407 INFO grin_util::logger - log4rs is initialized, file level: Debug, stdout level: Warn, min. level: Debug
20190110 16:01:17.407 INFO grin - Using configuration file at /home/userz/.grin/floo/grin-server.toml
20190110 16:01:17.407 INFO grin - This is Grin version 0.5.1 (git v0.5.1), built for x86_64-unknown-linux-gnu by rustc 1.31.1 (b6c32da9b 2018-12-18).
20190110 16:01:17.407 DEBUG grin - Built with profile "release", features "".
20190110 16:01:17.407 WARN grin::cmd::server - Starting GRIN in UI mode...
20190110 16:01:17.407 INFO grin_servers::grin::server - Starting server, genesis block: edc758c1
20190110 16:01:17.443 DEBUG grin_chain::txhashset::txhashset - Error returned, discarding txhashset extension: Other Error: output vs rproof MMRs different sizes 
 Cause: Unknown 
20190110 16:01:17.463 ERROR grin_util::logger - 
thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: Chain(Error { inner: 

Other Error: output vs rproof MMRs different sizes })': libcore/ backtrace:
   0:     0x563a258ce65d - backtrace::backtrace::trace::hd74837959dc31a2c