Install wallet + restore on ubuntu

Hi grinfriends,
I will try for the first time to restore my wallet with the wallet.seed backup after crashing my chroot on chromeos (crouton)
I compiled grin because the decompressed version didn’t work, I had a bug with the processor if I understood correctly.
So I have a node that is synchronized.
Where I would like help is with the installation of the wallet and the restoration, I don’t remember how I did it the first time. So I downloaded grin-wallet-v2.1.0-linux-amd64.tar.gz and now it seems to me that I just have to decompress it (I can’t find the tutorial I followed the first time) and I would like some help for the rest, so I don’t make mistakes and lose the wallet container: p

**Another question by the way, is the restore command valid if I compile and use wallet713?
***And my last question is about $PATH, with which I’m not comfortable, I feel like it doesn’t work every time however I run the command export PATH=pwd/target/release:$PATH

Thx in advance

EDIT : I think I’m on the right track.
But I encountered a problem, following the tutorial, grin-wallet init -h did not want to connect to my server, so I tried the command without the -h and it worked.
I then deleted the wallet.seed created and imported the wallet.seed (backup) I then placed in the folder with the .toml and started the restore grin-wallet.
I’m still waiting, it’s been charging for 30 minutes…

After 30min :

20191119 14:48:34.157 ERROR grin_wallet_impls::node_clients::http - get_outputs_by_pmmr_index: error contacting Error: Request error: Cannot make request: an error occurred trying to connect: Cannot assign requested address (os error 99)
20191119 14:48:34.157 ERROR grin_wallet_controller::command - Wallet restore failed: Restore Error
20191119 14:48:34.157 ERROR grin_wallet_controller::command - Backtrace: Wallet command failed: LibWallet Error: Restore Error

EDIT: I don’t understand what’s going on. I tried again and this time it was barely after 5 minutes that it stopped like that with the same message

Hello, after hours and hours of trying, I don’t know what to do anymore. I started the restore command at 2am and it turned at least 10 hours to end there.

PS : If anyone wants to take a look at it, I can send the log files

20191121 12:15:24.629 WARN grin_wallet_libwallet::internal::restore - Scanning 0 outputs in the current Grin utxo set
20191121 12:15:24.637 WARN grin_wallet_libwallet::internal::restore - Checking 0 outputs, up to index 2379191. (Highest index: 4758370)
20191121 12:15:24.637 WARN grin_wallet_libwallet::internal::restore - Scanning 0 outputs in the current Grin utxo set
20191121 12:15:24.708 ERROR grin_util::logger -
thread ‘unnamed’ panicked at ‘inconsistent state in unpark’: /home/vsts/.cargo/registry/src/ backtrace:
0: grin_util::logger::send_panic_to_log::{{closure}}
1: std::panicking::rust_panic_with_hook
at src/libstd/
2: std::panicking::begin_panic
3: crossbeam_utils::sync::parker::Unparker::unpark
4: tokio_threadpool::pool::Pool::signal_work
5: std::thread::local::LocalKey::with
6: <tokio_threadpool::notifier::Notifier as futures::task_impl::Notify>::notify
7: tokio_reactor::Reactor::turn
8: tokio_reactor::background::run
9: std::sys_common::backtrace::__rust_begin_short_backtrace
10: std::panicking::try::do_call
11: __rust_maybe_catch_panic
at src/libpanic_unwind/
12: core::ops::function::FnOnce::call_once{{vtable.shim}}
13: <alloc::boxed::Box as core::ops::function::FnOnce>::call_once
at /rustc/625451e376bb2e5283fc4741caa0a3e8a2ca4d54/src/liballoc/
14: <alloc::boxed::Box as core::ops::function::FnOnce
at /rustc/625451e376bb2e5283fc4741caa0a3e8a2ca4d54/src/liballoc/
at src/libstd/sys_common/
at src/libstd/sys/unix/
15: start_thread
16: __clone

Thread ‘unnamed’ panicked with message:
“inconsistent state in unpark”
See /home/rom/.grin/main/grin-wallet.log for further details.
Segmentation fault (core dumped)