Grin++ , send error, Solved

Trying to send grin from my Grinn++ to Tradeogre. but when I am trying the “SEND” button is not responding.
I tried to delete grin++ and restore. but I have same issue.

The title indicates solved may I ask how it was solved? I am having the exact same issue.

  1. Check that your node is synced
  2. Check that you run the latest version of Grin++
  3. If the above does not solve your issue, try to re-sync all blockchain data (resync button).
  4. If none of the above solves your issue, ask on the Grin++ telegram group Telegram: Contact @GrinPP

I got it to work. In my case, I didn’t realize that it has to be a whole number amount. Once I removed the decimals from the amount to send, it worked fine.

That is an interesting bug/feature. Probably you used more decimals than allowed. Grin works in nano grin, so 9 decimals after the “.” works fine, anything more and you cannot send because the blockchain does not allow you to send anything smaller than a nano-grin.

Yeah. I had just hit the max button. Which is weird as it seems to be ok now with using the max button.