Grin command not working?

Is grin command working for anyone else?

When I try to run grin command it just freezes terminal…

1 Like

Show us how you are trying to run the grin command? And what do you mean by “freezes the terminal” ? What exactly do you see happening in the terminal? CTRL-C does not end the command?

This happens

1gb in the server’s name means only 1gb of RAM ? Maybe not the issue since I just tried running on VMWare with only 1gb of RAM and 1 VCPU and it worked

How do other commands perform on your VPS? Does the system feel sluggish? Some VPS providers are known to have more customers/VPS than their hardware can really support and it shows in the performance of the VPS. How long have you left it running to see if anything happens?

P.S. Why are you running it as root? Never a good idea. You should set up a non-root user and use that for grin.

I have 8gb ram and 4 vcpu’s


Also, it runs fine. the problem started just yesterday. And it feels normal. grin the only command that isn’t working correctly.

This is the first time I’m ever running Ubuntu. I don’t know how to create non-root user.

Ok the command is starting to run now. I think the developers where doing something to it idk. but it works now.

1 Like

Digital Ocean defaults to root, you need to setup a non-root user, here are instructions