Trouble installing on linux vm

Hey crew,

I’ve installed grin on ubuntu 18.04 virtual machine. It seems like everything went okay with the installation, and I can startup the grin client and connect to peers.

Yet it will not download the headers, getting stuck at 0% of step 1/4.

The VM has fine internet connection, I’ve tried opening the internet and testing streaming videos.

Has anyone else had a smooth experience installing grin on a vm? Any tips?

I have ran Grin inside a Ubuntu VM before without issue. Are you connected to any peers?

yeah, 23 at one point.

Perhaps I’ll just try making a new vm with some more ram? I’m using 4gb right now with 50gb of storage. I don’t know if it’s the settings or virtualbox, but there is a little bit of lag when using the system so I wonder if that’s contributing.

The fact that yours worked smoothly gives me hope. I just wasn’t sure if it was the VM causing issue.

If it still doesn’t work, remove the logs, restart, let it run for a couple minutes and then post the new logs. That would help in diagnosing the issue.

1 Like

Thanks for the tip, will retry after work today :zap: