Command 'grin' not found, did you mean: Your a Linux noob -yes, I am

Hey everbody, I have ubuntu as WSL installed yesterday.

Followed the instructions from this page:

But now, I get this (I am a total noob, I dont know how to start the node or install the wallet):

vox@DESKTOP-MAMAXR0:~/grin/target/release$ ls
build deps examples grin grin.d incremental native
vox@DESKTOP-MAMAXR0:~/grin/target/release$ grin

Command ‘grin’ not found, did you mean:

command ‘grpn’ from deb grpn
command ‘gcin’ from deb gcin
command ‘grn’ from deb groff
command ‘grind’ from deb wordnet-grind
command ‘grip’ from deb grip
command ‘grun’ from deb grun
command ‘gri’ from deb gri
command ‘grig’ from deb grig

Try: sudo apt install

vox@DESKTOP-MAMAXR0:~/grin/target/release$ $HOME/grin/target/release/grin

vox@DESKTOP-MAMAXR0:~/grin/target/release$ ls
build deps examples grin grin.d incremental native

… is everything build correct?

vox@DESKTOP-MAMAXR0:/home$ cd vox

Downloads grin
vox@DESKTOP-MAMAXR0:~ cd grin vox@DESKTOP-MAMAXR0:~/grin ls Cargo.lock LICENSE chain core etc p2p rustfmt.toml src target wallet Cargo.toml api config doc keychain pool servers store util

Help is appreciated

Instead of grin try ./grin

The reason you need to write ./grin instead of simply grin is to specify that it is not a global script (which is how it is interpreted with the latter syntax), but a script that resides in the current working directory (represented by .).

Best add the directory containing the grin executable ro your $PATH …

even ./grin has no effect, hm.

Adding the directory with the grin executable to my Path …~/grin$ echo export PATH=/home/vox/grin/target/release:$PATH works. But does not help.

Have tried it this way: (downloading: tar xzf grin-v0.5.2-478131988-linux-amd64.tgz), same problem. Maybe it has something to do with WSL.

Nevertheless many thanks

There are better guides now at the below link to install node and wallet using the binaries…if you’re a noob to Linux like I was a few weeks ago and unless you enjoy fiddling around with a lot of unfamiliar commands and guide that assumes you have good tech. understanding it’s prob. a lot less frustrating …:wink:

Oops… Sorry- I see you tried that too :frowning:

Ya, sadly that does not work, but thanks

This guy gives a fairly decent step-by-step guide on how to set things up using a self-build approach rather than using the bnaries - it’s from when testnet 3 was up a couple of months ago but the principles are the same - it helped me get things mostly working…

This guide also looks suitably detailed (disclaimer: I have not used it mysefl):

You can simply create eg a grin directory in your home directory.
Then copy your nice compiled grin in ~/grin
Make sure to have ~/grin in your $PATH, and that should work.

That was the problem: Node and wallet do not work with with Windows Subsystem Linux (WSL).
And I use WSL.


try sudo su first
then run grin
it would work. This error occurs because your grin folder is in root directory and you cannot access it without superuser privileges
I had written full node setup and other errors if you are facing any you can check them at

WSL isn’t perfect.
Use virtualbox.
And then ssh

use screen or tmux for multi tabs