Bminer 15.7.6 Fix Cuckaroo29d on RTX-series cards

The current bminer doesm’t support name miners machine respectively, to better support grinmint or other pool, maybe you can support take parameters from a json file to make it better comply with official protocol.


i see a lot of ({“code”: -32501, “message”: “Share rejected due to low difficulty”}) errors with your miner on different pools.
Is this miner related ?


anyone mining with bminer on sparkpool ?

HI , Im using Bminer with 6 1060 6gb cards but this is what i get when starting:

NFO] [2019-01-18T16:19:29+01:00] Bminer: When Crypto-mining Made Fast (v12.1.0-5083c32)
[INFO] [2019-01-18T16:19:29+01:00] Watchdog has started.
[INFO] [2019-01-18T16:19:29+01:00] Starting miner on 6 devices
[INFO] [2019-01-18T16:19:29+01:00] Connected to
[WARN] [2019-01-18T16:19:29+01:00] Get error: End of file, resetting in 5 seconds
[FATA] [2019-01-18T16:19:29+01:00] Insufficient memory 5029 MB available on device (#0). Unable to run the solver
[WARN] [2019-01-18T16:19:29+01:00] Miner died! It will be restarted soon…

Any idea how to fix?
Using Cuda version 9.2.127 (and 10+ on other miner with 4 cards same result)

Also getting this error: CUDA error DRIVER: ‘209’ in func ‘Initialize’ line 92

CUDA 10 is installed.

CUDA error DRIVER: ‘209’ in func ‘Initialize’ line 92

Nothing received. Please respond timely to compliance requests…

I keep getting this error " get error end of file resetting in 5 seconds " how to fix that?

We will fix it soon. Thanks for the feedback.

please fix asap we want use bminer on other pool every one switch to f2pool and already have 50% hashrate

is Legit to run a closed source miner? i mean…probably you can expose your credential pool at the miner…

I’m seeing the error n the image.
CUDA error DRIVER: ‘2’ in func ‘bminer::cuckoo::CuckarooSolverCuda::Initialize’ line 116
I’m running 7 GTX 1070 TI cards
Driver is NVIDIA 417.71 from 1/15/19

By switching to only using 6 devices, this issue resolved.
Both of the following arg settings worked, so it’s not the card or the fact that it’s dev 6
-devices 0,1,2,3,4,5
-devices 1,2,3,4,5,6

1 Like

This is not open-sourced, right? Mind updating your FAQ?

It’s possible to mine on Sparkpool follow this config
bminer -uri cuckaroo29://
The local output will go well but there is a problem to see the worker name on the pool which we will be fix soon.

1 Like

it would be helpful if you can share the command line here. looks like that there is something wrong in it.

any plan for C31 algorithm? thanks!

i was mine on sparkpool but my hashrate was very low but maybe my bat file was wrong
bminer -uri cuckaroo29:// but i see my worker

Please see Bminer 12.2.0, it is fixed.

1 Like

Bminer 12.2.0 allow bminer to run with older NVIDIA drivers already.

how to use on grinmint pool ?? share config file please