Bitmesh withdraw ends with failed even though it worked first time

I did a test withdrawal of 0.2 Grin and I received it fine in my wallet so everything was working as expected. But my withdrawals after this test withdrawal are not going through.

My address is I have tried restarting the node and wallet listener but the withdrawals are not going through when trying to withdraw the remaining amount of Grin.

I checked my address and port and it is open.

Here you can see my 1 successful transaction and the 3 failed after that

A curious thing is that they do arrive as “awaiting confirmation” in my wallet.

Does this mean that it actually was successful in connecting to my wallet?

Btw. I am running the node on a google cloud instance,

Any help would be apreciated! What do you think could be wrong? Do you think it’s an issue on Bitmesh side?

Hmm, I was now successful withdrawing without doing anything special. Probably an error with Bitmesh.

Still unclear about how long the “Awaiting Confirmation” will stay there. Should they disappear automatically?