Testnet Mining: Cannot connect to pool


I receive one of the testnet miners from iPollo and noticed yesterday that the G1 mini was not connected to the testnet mining pool.

To ensure that this was not a hardware issue with the miner, I tried to connect to a different pool (2miners) and the G1 mini was able to connect without any other issues.

So, I’m inclined to believe that this is probably related to my pool configuration and wanted to get your feedback.

I’ve attached a few screenshots here show my setup and what the dashboard displays for the miner. Please let me know if anything is incorrect and how we can fix this.


1 Like

@Mattczt tagging you for visibility

I have the same problem too, please keep your mini with the same configuration for now. David said he will look at the server later.
I have set up a local stratum, so testnet is running again.


Sure thing, thank you for the update.

1 Like

We still have a problem with the server, ive managed to get it running again locally.
Does your miner say its connected but showing 0gs?

1 Like

Hi, actually it appears to be hashing for the past 24 hours:

1 Like

Hi guys, it seems Test miners are not running at the moment. We need to run and test stuff in development.

@Mattczt @navie.

It’s online but not accepting any work at the moment. I’ve tried resetting it a few times.

Update: Now it’s doing the same thing as my message in thread on Jan 27.


Maybe you need run on your own Startum server on testnet ?

Maybe, but let’s wait for Matt to reply. He did something last time that fixed the issue so he’ll probably know what to do. :slight_smile:

1 Like

I have not looked into it yet, it seems like a problem on the server, actually David fixed the issue last time but i will see what i can do.

1 Like

Try your miner on the server, mine is working now

1 Like

I just reset the miner but I’m experiencing the same issue as before. It’s getting work but not accepting anything. The hashrate is also always 0.00 Gps.

The pool settings are also the same as before.

I feel like this is a problem on the miner side, did you say that it works on another pool though?

John Davies has set up another server, you could try it.

Paste this to replace the ip address and port in the settings on pool 1

1 Like

Hi Matt, I was able to connect to John Davies’ server. I think something might be going on with the original testnet server (stratum+tcp://, I am able to connect to other mining pools pools.

Hi, @Cobragrin. The testnet miner is back up again!


Thank you @navie ! :vulcan_salute:

And sure thanks to @johndavies24 and @Mattczt :+1:


Can someone confirm if this setup is okay? As we are mining on different servers we will probably get frequent reorgs. If it is a problem i can move to John Davies server too.


That’s not a problem. Small reorgs are fine and normal.

Hi @Mattczt @johndavies24 , I just checked my testnet miner and it’s doesn’t appear to be connected to John Davies server. Could you confirm if your miners are working on this server?

[Firmware Version] => microcomputer - 20220323
version: v2.4.9
luci: 59309ba
cgminer-packages: f1e04dd
openwrt: e4dcc51
commits: 56156
Socket connect failed => Connection refused

1 Like