Solved: Failed to Restore a 24 word seed on grin++

Hi guys ! I’m new to grin
Yesterday I tried to restore a 24 word mnemonic seed on grin++ from an older version of grin++ (with no funds in it) and it failed. I also tried to restore a 24 words seed on grin++ from a ledger nano s wallet it failed too. Also there is no possibility to add a passphrase.
I’m in luck it was just a test and there was no actual money at stake.
This is one of the reasons why i’m thinking maybe it’s safer to keep funds on an exchange until maybe grin is supported on the ledger nano s and more stable ?
Any thoughts on why this happent?

I don’t get it. You tried to restore a wallet from a grin seed using grin++ and it failed? What was the error message?

Yes. it said that the mnemonic was invalid but I triple checked them. What I meant is I tried to restore actually 3 wallets on grin++ and they all failed to be restored.
1 24w seed that I got from grin++ but an older version of it
And 2 seeds that I obtained from a ledger nano s
I didn’t try to restore a 24w seed obtained from the latest version on grin++ I wonder if that would work

As an long term crypto user, I did learn a valuable lesson over the years:

`No Keys not Your Coins"

Which means, keeping coins in your own wallet is better then keeping them on any exchange for longer then needed. I do know for new users to the crypto space its hard to understand but we have seen exchanges failing and closing without any notifications.

When you interested in a new coin, I would always recommend to get familiar with the wallet and transactions using small amounts or the testnet as every coin has a testnet.

Using a new wallet requires you to do at least these steps always:

  • download it from a trusted source
  • verify the download via HASH (sha256,etc) values
  • keep a copy of the downloaded wallet in your backups
  • backup your seeds (physically not digitally)
  • fund the wallet with a small amount
  • delete the local wallet completely
  • restore the wallet using your seed.

But also let us know what your error where when you did try to recover your GRINs.


nevermind it worked ! I retried today (using a short wallet name with only letters or numbers) and it worked ! :)))

1 Like

Interesting, so maybe creating a wallet with a very long name somehow creates issues. Strange. Or maybe before you made some typos, happens to all of us.
If anyone encounters a similar issue, I also have a Python script that tries the minimum amount of swaps between words (so if you made a mistake in the order), that results in a valid checksum (the last word of the mnemonic). DM me if anyone ever needs it.