Runnig a Grin node on Google Cloud

I followed the instructions on How to: Run a Grin node on Google Cloud for free (https://github.com/mimblewimble/docs/wiki/How-to:-Run-a-Grin-node-on-Google-Cloud-for-free)

I completed the setup and am ready to receive floonet grins. When I enter ‘curl gringod.info’ I get the following message:

##########################################################

Grintings stranger, we can’t send grin to you now.

Your wallet is inaccessible @ 13415 from outside

##########################################################

  1. Check your router forwards port 13415 to this PC
  2. Check that you have wallet listening on 0.0.0.0:13415
    Or on your public IP 34.73.229.124:13415
  3. Make sure you are running both GRIN node and wallet listener (grin wallet listen)

Two questions:

1-If my node is running am I still getting the Grins I mine?
2-What can I do to resolve this problem? Are there specific instructions I can follow to resolve this or is there another way I can get the wallet to work to get the Grin?

Floonet is for testing only and the coins have no value.

You want to be on mainnet - https://github.com/mimblewimble/docs/wiki/How-to:-Run-a-Grin-node-on-Google-Cloud-for-free#syncing-a-mainnet-grin-node

gringod.info is obsolete, you should’t be using it to validate your setup as the default port that the grin wallet listens on for mainnet is now 3415 not 13415

Check with a website like https://www.yougetsignal.com/tools/open-ports/ with the remote address of your Google cloud instance (34.73.229.124 ?) and port 3415.

Thank you for your response. I followed the instructions for mainnet. This is what I got after I entered all the details:

XXXXXXXX@grin-node1:~$ gcloud compute firewall-rules create main-wallet-port --direction=INGRESS --action=ALL
OW --rules=tcp:3415 --target-tags=grin-node
Creating firewall…failed.
ERROR: (gcloud.compute.firewall-rules.create) Could not fetch resource:

  • Insufficient Permission: Request had insufficient authentication scopes.
    XXXXXXXX@grin-node1:~$

@tromp is it possible to mine with the G Cloud setup? I’m successful up to the point of running the Node, Wallet, but my miner fails often. I’m not sure if it’s my settings or whether I’m not using the mining executable.

Any suggestion would be greatly appreciated.

So I tried to set this up a while ago but I don’t think it managed to complete all of the steps. I’ve now started being charged $4.57 pm. Just wanted to know if anyone else is using it.

I think Google-Cloud gets expensive, when you really are using it for a simple GRIN-Node.
But something interesting could be a GRIN-Node on a Raspberry-PI , we are working on an easy deployment and also thinking of giving some away in a future GRIN-Node Challenge.

GRIN-PI: GitHub - Grinnode-live/Grin-Pi: Raspberry PI Grin Node

4 Likes