Node Keeps Throwing Illegal Action Error

Just downloaded the node software and tried to run it for the first time, it gets to step 3/4 when it tries to verify and immediately throws an illegal action error…

ive followed the guide to a T so im not sure what is happening

You need to provide a bit more information. What is the exact error message? Did you build it yourself or are you running the pre-compiled binary? Are you on version 2.0.0 or some other version?

I am running 2.0. and no i didnt build it myself i just downloaded extracted and followed the instuctions from the grin guide on how to run a node…

the exact error is Illegal Instruction , right after it completes the download of chainstate 2/4 and switches to 3/4 preparing chain state for validation a normal command prompt pops up over the TUI in the bottom left corner saying Illegal Instruction and it just hangs there till its closed…

I havent edited and files, i followed the guide to a t, so made sure rust is uptodate etc…

cant find anyinfo anywhere

running Debian 10 by the way

I guess this is due to the CPU spec not support the code.

Had the same issue when i frist tried to run grin and i had to compile it for my machine to get it going.

edit: afaik the pre-build version assumes your cpu supports e.g. avx2

Yea someone told me to compile it on discord last night and I tried that now it just freezes up when it gets to the same place of 3/4 rather then throwing the illegal error like it was before.

Kind of sucks because I want to get some grins and run a node but I have android and there’s no other wallets I can find and I can’t get this to work.

Not sure if I screwed up when building it but I don’t see how

yeah, early days :confused:
you could try to delete chain_data and start over. i had to do it after being stuck at a certain block. Did you pull the latest master from github?

Yea grabbed the master from git.

I had deleted it and started over when I built it so don’t think that will help. But can you just tell the tui to delete the chain data?

Are there any android wallets? Also does anyone know if I can’t get this node to work is it safe to assume the miner won’t work either ?

I’m not the most technical person so I could just be doing something wrong but I mean I have coding experience as well as working with Linux and I clearly can figure out how to build stuff from source etc.

But is there a log file that someone would be able to read and tell what is going wrong?

the node is the backbone for the miner if you want to be your own pool, otherwise you can just run the miner and point it to a pool. No android wallets yet.

You can tell the node what to log so tell it to debug and look at the server log

Right on should of thought of that . I’ll take it for a spin and see what happens.

Thanks for the help my friend.

1 Like

This is during sync? Just be patient, the node is validating the chain state

1 Like

yes during sync as soon as

status: 3/4 it just freezes i can no longer move around the UI etc and ive let it sit for quiete a while before closing it… before i compiled it would throw an illegal action error at this same point…

ill try it out and just let it sit

Also make sure you used cargo build --release and run from target/release/grin or your node will be significantly slower.

1 Like

I got it… Geez man i must just be gettin impatient… I let it sit for like 20-25 minutes on two seperate occasion and since my cursor froze both times i assumed the node had crashed as I was getting the illegal action error before…

But just as jaspervdm said i just left it for about a hour and came back and it was totally synced and workinig…

Thanks alot man… Now off to get some GRIN

So how you fixed your issue? I have a spare vps which has same issue like yours.

pull from master, build, start & wait