GPU won't hash mac os catalina

I have a 2012 mac pro 5,1 with a sapphire radeon pulse rx580 8GB video card on mac os catalina.
Installed node, wallet and miner from github source code
Everything runs, CPU mines (turned it off after test because I’m mining xmr with the cpus and I want to GPU mine grin)

Miner has no problem connecting to grinmint pool. It says it’s getting new jobs, etc. I just get no hash.
On quit from grin-miner gui in terminal it says:
thread ‘’ panicked at ‘can’t build trimmer: Can’t find OpenCL platform’, src/libcore/

note: run with RUST_BACKTRACE=1 environment variable to display a backtrace."

my config for gpu is:

plugin_name = “ocl_cuckatoo”
platform = 1
device = 0
edge_bits = 31

if I use platform = 0 it makes an error in the gui that I can’t copy/paste

I had an issue with the xmr-stak-rx miner where I couldn’t get it to gpu mine at first too, but I kept messing with it and eventually got it working (I shut it off because gpu mining xmr took up too much system resources and used too much power for the small contribution it made to my overall hash rate - it really made the screen lag terribly)
It had something to do with an open cl library dependency that needed configured and either my anti virus or the sandboxing in catalina wouldn’t let it configure automatically.

Ideally, I’d like to mine xmr on 6 of 12 cores on my cpus, and mine grin on my gpu at the same time. If the grin miner using the gpu makes it lag too much while I’m using the box for other tasks I’ll just shut it down to use, say lightroom, and restart it while the box is otherwise idle.

To top it off, I’m a noob to mac os, having just gone over to the darkside a few months ago when windows wasn’t cutting it for photo, video, and audio editing. I’m also a complete noob to mining.

I’m not really looking to mine for profit or I’d build a serious rig. I’m just trying to learn about crypto and support the projects I think are cool. I like to tinker with things, and I was hoping to get this working on my own, but the grin miner is stumping me and the project is new enough there’s not much info to google. I probably have a rare use case anyway: grin-miner on mac os catalina with rx580 8GB.

One of the things that attracted me to grin was that at least the early projects say the software only support mac and linux, so I figured I would be able to get it to run on a mac.
Also was looking for a GPU optimized coin, privacy based, that’s early enough in it’s development history to be paying out good sized blocks.

I’m open to any suggestions. I’ll keep messing with it, but I’m about at the extent of my skill set currently.



You might have better luck dual booting your Mac with Linux thb. It sounds like you are trying to run the stock grin miner. Maybe try finding a different one that supports MacOS. Based on your errors, it looks like the miner does not have access to opencl compute libraries for your GPU. Might just not know where they are since MacOS is a bit different.

From what I remember with the stock miner you have to build the OpenCL plugins for AMD.
Personally I use an alternative miner, but you might not have a choice with MacOS.

Maybe give this a try.

Hope this helps,


Building the OpenCL plugins

OpenCL plugins are not enabled by default. Run script to build and install them.


You must install OpenCL libraries for your operating system before. If you just need to compile them (for development or testing purposes) build grin-miner the following way:

cargo build --features opencl
1 Like

Thanks so much for your reply!

I’m not interested in booting another os on my mac because I use mac os for my daily computing tasks. Even when there’s gpu lag on it that makes it unusable locally I can connect to it by screen sharing from an old macbook running lion I have and use it that way.

I am using the stock miner because it claimed to run on linux and mac os.

I assumed there is an issue with the open cl libraries as I had a similar issue with xmr-stak-rx which I was eventually able to resolve by futzing around.

The step by step instructions link you included is the one I used to install the node, wallet, and miner. I note that it is for Mojave, and I’m using Catalina - not sure if that makes a difference. Apple has depricated open cl in favor of their own metal graphics, and I’d read something about the sandboxing in catalina being different from mojave - not sure if that makes anything different. I do have sip disabled to avoid sip conflicts with my developement environment.

Haven’t found any source code to install the open cl libraries on my system to insure that if apple had not included them with catalina I’d have them.

I built the plugins for open cl when I built the miner. I can get the miner to start and run without errors sometimes by changing the settings in the config file, but it still doesn’t show the gpu as a device inside the gui and it doesn’t hash.

I’ll probably delete and rebuild the miner today from source following the instructions in that link again just to insure I didn’t make any errors the first time.

I have another older mac pro running sierra I thought I might try to install the node, wallet and miner on that to see if it would run but my belief is that the E5462 processors don’t support the instructions for gpu hardware acceleration and that the radeon 5770 won’t gpu mine either. I know I tried to install a rx560 in that box and it wouldn’t work even tho 10.12.6 sierra is supposed to include all the drivers for that card.

1 Like

ok I rebuilt the miner like this:

git clone
cd grin-miner
git submodule update --init
cargo build --features opencl

it can’t find the cuckaroo or cuckatoo plugins (tried both)

" Starting Grin-Miner from config file at: /Volumes/Raid10/Admin/grin-miner/target/debug/grin-miner.toml

Error loading plugins. Please check logs for further info.

Error details:

PluginNotFoundError("/Volumes/Raid10/Admin/grin-miner/target/debug/plugins/ocl_cuckaroo.cuckooplugin - Custom { kind: Other, error: “dlopen(/Volumes/Raid10/Admin/grin-miner/target/debug/plugins/ocl_cuckaroo.cuckooplugin, 2): image not found” }")


I think this happened last time too, I’ll keep messing with it

1 Like

merged the plugin directory from my prior build with this build

miner gui started without error, connected to grinmint pool, gets new job - etc., shows device but not device name, gps is inf so not hashing.

on shut down (Q in GUI) same error:

Starting Grin-Miner from config file at: /Volumes/Raid10/Admin/grin-miner/target/debug/grin-miner.toml

Starting Grin Miner in UI mode…

Waiting for solvers to shutdown…

thread ‘’ panicked at ‘can’t build trimmer: Can’t find OpenCL platform’, src/libcore/

note: run with RUST_BACKTRACE=1 environment variable to display a backtrace."

obvs def something with the open cl libraries

1 Like

1 Like

Try using v2.0.0 of the miner instead of the beta. You could also try an unencrypted connection to the pool. Unless someone else here can help, I would recommend submitting an issue with the miner.
It seems like you are following their configuration correctly, so there is only so much you can do at this point.

They should be able to help you out :slight_smile:

Thanks, Macker

1 Like

Funny you should mention it, I tried v2 of the miner after I made these posts yesterday, lol
I don’t have any trouble connecting to the pool, but I have tried both encrypted and unencrypted connections - no difference.

Good idea to go ahead and contact the miner team.

1 Like