Gin-Miner Stuck in "Waiting for Server" / NVIDIA CUDA Toolkit and CUDA Plugin Issues

Hey guys, when I run grin-miner, it just says:

Connection Status: Starting
Mining Status: Waiting for server

I have a node spun up in bare metal Ubuntu 18.04.2 LTS with a wallet working correctly (recovered and restored a wallet to it’s correct GRIN value, and ran grin wallet check successfully with an up-to-date node, got no errors, assume wallet is configured properly), a wallet listener running, and grin-miner installed. I have enable_stratum_server = true in both /grin/grin-server.toml and /.grin/grin-server.toml.

Also I’m having issues when I comment in the CUDA plugin in grin-miner.toml, grin-miner gets an error and won’t start. How can I make sure my CUDA Toolkit and CUDA plugins for grin-miner are configured properly?

So now I have the Cuckaroo 29 CPU plugin commented in, but the CUDA plugin and OpenCL plugins commented out, trying to see if I can get a CPU hash rate at least. So I’m able to run the miner, but the status never changes beyond Starting and Waiting for server.

I’m using an Intel x5650 cpu overclocked to 4.2GHz. It has 6 physical cores, and 12 virtual, so I set nthreads = 6.

Also, I had issues installing CUDA toolkit and NVIDIA drivers (running a single GTX1060 6GB for now). Sudo apt update was only getting me version 9.x

Did this:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo ubuntu-drivers autoinstall
sudo apt install nvidia-cuda-toolkit gcc-6
nvcc --version
Fuck, not CUDA 10.x

Ran this and thought I had it.
sudo apt-get install cuda-toolkit-10-0

export PATH=/usr/local/cuda-10.0/bin${PATH:+:${PATH}}

nvcc -V
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2017 NVIDIA Corporation
Built on Fri_Nov__3_21:07:56_CDT_2017
Cuda compilation tools, release 9.1, V9.1.85

Thu Feb 14 04:25:56 2019
| NVIDIA-SMI 415.27 Driver Version: 415.27 CUDA Version: 10.0 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce GTX 106… Off | 00000000:02:00.0 On | N/A |
| 0% 38C P0 25W / 120W | 454MiB / 6070MiB | 0% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
####Censoring the rest of this output…

I usually remembered this command before trying to build grin-miner:
$ git submodule update --init
But also tried it without either by accident or because some guides leave it out.

I think I successfully built grin-miner with the following command because all the other build commands for this step that I could find gave me build errors and failed to complete, but this one apparently went smoothly:
CUDA_HOST_COMPILER=gcc-6 cargo build --features opencl

Other build commands I tried:
cargo build
cargo build --features opencl
CUDA_HOST_COMPILER=gcc-6 cargo build

All of those unsuccessful builds would fail with something like this:
error: failed to run custom build command for cuckoo_miner v1.0.2 (/home/user/grin-miner/cuckoo-miner)
process didn’t exit successfully: /home/user/grin-miner/target/debug/build/cuckoo_miner-f7e79719252ccbc7/build-script-build (exit code: 101)

When I quit out of grin-miner, “waiting for solvers to shut down” seems to take a while for some reason. Does CTRL+C’ing the terminal during this solver shut down cause issues? I haven’t been patient enough to wait for it yet…

Anyway, so how can I show you guys what you need to see to diagnose this? Shouldn’t my CPU mining “work” (I know it will suck, proof of working installation is what I’m shooting for here) even if CUDA Toolkit or CUDA plugins are misconfigured?

How can I diagnose this CUDA Toolkit version discrepancy and ensure I’ve configured grin-miner properly for GPU mining?