Connecting iPollo G1-mini to iMac

I’m trying to connect the iPollo G1-miner that I unboxed yesterday to my 27" iMac running the latest maOS Catalina 10.15.7

I found the miner on cabled ethernet at
$ arp -a
johns-imac.local (169.254.178.245) at 68:5b:35:99:ee:87 on en0 permanent [ethernet]

and can ping it as soon as the miner is done booting.

But all my browsers (Safari/Chrome/Brave) report
169.254.178.245 refused to connect.
For good measure I also tried

$ login 169.254.178.245
Login incorrect
login: admin
Login incorrect

Any suggestions on how to proceed?

i login in my g1-mini with ssh

ssh admin@g1-mini.ip
password admin

it is openwrt os system.

$ ssh admin@169.254.178.245
ssh: connect to host 169.254.178.245 port 22: Connection refused

Is it possible there’s another IP besides the one I can ping?

My wife suggested connecting the device to our ISP router instead of to my iMac. That worked. The ISP router webpage showed the IP address of the “OpenWrt” device, and I easily connected to its webpage.

It reports running at 1.47 Gps, and submitted 13 shares in the 7 minutes it ran. I can’t leave it running in my living room though as it’s too noisy.

2 Likes

I bet they used DHCP to assign an IP address. This could be the problem, why you didnt get a correct address to start with.
But once I get the miner I do some networking tests and see if everything is fine and the miner is not doing anything it should not do.

So far the G1 mini miners are even performing better than market. I only run them for 24h but I got 1.91 G/s in the last 24h opposed to the marketed 1.5. Some longer tested are needed to put any significance to it, but so far I am very satisfied.

I managed to set it up for solo mining.
I’m running a grin server node with

#whether stratum server is enabled
enable_stratum_server = true

#what port and address for the stratum server to listen on
stratum_server_addr = "MY.IP.AD.DR:3416"

where MY.IP.AD.DR was determined by logging in to my local routerbox and looking at connected devices. I also run

grin-wallet listen -n

to mine into my wallet. Running

netstat -a -n | grep LISTEN

confirmed that my iMac was listening on the right port (its firewall being turned off by default).
At first I had trouble having the G1-mini connect to my grin node, but it turns out that was because I had left the Pool worker and password blank in the Pool Configuration. After putting in arbtrary text there, I saw the worker connect in the Mining Server Status TUI.

With an expected 2 coinbases per week, I’d rather mine solo than use a pool.
It also helps to decentralize Grin.

Btw, mine shows the temperature always at 0C. Does anyone have actual temperature readings?

8 Likes