AMD Miners - are they being built?

I tried running ./ on mac os Mojave. But I’m getting this error:
cp: target/release/ No such file or directory

Building ocl_cucka(r/t)oo doesn’t seem to create the .so files, so I have no files to move to the plugins directory.

Does anyone know a solution for this?

the script was maybe written for linux, the libs you are looking for are most probably in target/release/deps dir.

if i do cargo build --release --features opencl on mac, this is what i have in target/release/deps

staff-iMac:grin-miner staff$ ls -al ./target/release/deps/libocl*
-rw-r–r-- 1 staff staff 3626378 Jan 13 20:17 ./target/release/deps/libocl-eafb079466bb6e26.rlib
-rw-r–r-- 1 staff staff 2996878 Jan 13 20:16 ./target/release/deps/libocl_core-baa11463a80c7f33.rlib
-rw-r–r-- 1 staff staff 5102702 Jan 13 20:15 ./target/release/deps/libocl_core_vector-df8b6da766caed66.rlib
-rwxr-xr-x 1 staff staff 999032 Jan 13 20:17 ./target/release/deps/libocl_cuckaroo.dylib
-rw-r–r-- 1 staff staff 1130226 Jan 13 20:17 ./target/release/deps/libocl_cuckaroo.rlib
-rwxr-xr-x 1 staff staff 938792 Jan 13 20:17 ./target/release/deps/libocl_cuckatoo.dylib
-rw-r–r-- 1 staff staff 1023606 Jan 13 20:17 ./target/release/deps/libocl_cuckatoo.rlib

what folder are you running that from?

I’m running it on the repo root directory.

I’m only getting libocl_cuckaroo.(d/dylib/rlib) files on target/release directory.
Someone said .so and .dylib files are equivalent so I moved libocl_cuckaroo.dylib to plugins/ocl_cuckaroo.cuckooplugin. But now, I get this error when I run grin-miner:
‘can’t build trimmer: Can’t find OpenCL platform’

please read my guide for linux here: AMD grin-miner error
you need to check your grin-miner.toml configuration file again. try to set the “platform” variable from 0 to 1 or 2 in the plugin configuration section

i don’t think i moved any files around, just ran the right where i found it (grin-miner folder) moves target/release/ to target/release/plugins/ocl_cuckaroo.cuckooplugin
I moved the .dylib files instead.

this error, ‘can’t build trimmer: Can’t find OpenCL platform’ seems to be because I set platform as AMD. I should set it as 0 because MacOS has its own opencl implementation.
I also set device as 1 to point to the mac gpu.
The miner runs now, but I’m encountering an error. I think because my GPU only has 4 gb memory.

Yeah, didn’t think about OSX, sorry, replace .so wirh .dylib

PR has been merged, test if you can, we will try to make a binary release soon

Hi yup, using the .dylib files, I was able to mine using ocl cuckatoo plugin

Testing right now and working, went from 0.84 gps to 1.42 gps on my RX 570.

Vega56 went from 1.9 GPS to 2.9 GPS! NIce.

Does this implementation for AMD miners do multiple threads?

I remember it was a similar bump in hashrate when running on XMR-Stak.

Hi, can I ask, how much memory your RX 570 has?

vega56 runs a little hot and locks up after a few mins, even with fans @ 90% is there anyway to de-tune is 5 or 10 %


just wanted to mention, it also locks the miner software hard, does not exit gracefully with ‘Q’ , but the amd’s do that when the go off the deepend

Whats the status on 4gb polaris GPUs? Any hope of a PR in the next few days @hashmap? Thanks for your work!


I heve RX580s 4GB aтв when i run the miner it normally launches and when it says STARTING it immediately changes to NO MEMORY status. Also it has a messaage saying “GPU Ellesmere ID 0: unable to allocate buffers, out of memory?”. I suppose it is because of the 4GBs of RAM. Are there any plans to enable these version to mine too, if so when? Thanks.

That doesn’t sound right. My Vega 56’s are drawing less power and running cooler than they were mining Monero.

In another thread you say that you managed to get 0.6-0.9 GPS from 4 GBs, which miner do you use? The drivers are Adrenaline or Crimson?

there is only one miner available for 4gb amd gpus afaik, the one provided by os. but, you have to install the whole os on your rig, not just the miner. and the hashrate is just 1/2 compared to 8gb amd card.

Thank you! Guess I will be waiting for another option cauze installing the whole OS seems to be too much to me.