Grin++ v1.0.2 missed server_config.json

OK, do not delete anything. Put this file:


With the name: server_config.json at ./GrinPP/MAINNET/.

Slow internet 40kB/s

No worries, do not delete anything, put that file there and let me know.

With v1.0.5 after login you will be able to backup your Seed.

Thanks. Seems to work again.

In the old file server_config.json was>

	"P2P" : 
		"MAX_PEERS" : 50,
		"MIN_PEERS" : 15
	"WALLET" : 

Yes, that was the issue. Now, let’s backup your seed…

After login, click on Settings (the third icon from left to right):


Then, click on the button with the Key icon.

A prompt will appear asking for a password, type the login password and click on “Confirm password”. This will display your Seed, please, make sure of writing down on a safe place.

Thanks. I have my seed a available. With Horkruxed seed I meant, a plan to decentralize the seed later. For example by making several (maybe 4) lists with only part (maybe 70%) of the information each. Then hiding them in different places. Then it would be work again to get at least two lists.

So, is Grin++ v1.0.5 working fine for you?

It has status “Running”.
Wallet is showing the correct number of grin.
There is a turning cycle “Trying to get your address, please wait…”
Have not tried to spend coins yet.

Cool… let’s try something.

Attempt #1

Logout, close the wallet, open the wallet again and login.

Attempt #2

Close Grin++, then make sure tor.exe is closed and open Grin++. If you don’t know how to manage the command line, just logout or restart Windows :sweat_smile:

Attempt #3

Let’s create a bridge, maybe your ISP is blocking Tor connections. For those of you who live in places where tor is blocked, you can now use an obfs4 bridge to get around this issue. Just create a text file, and save it at ~/.GrinPP/MAINNET/TOR/.torrc (mac/linux) or %userprofile%/.GrinPP/MAINNET/TOR/.torrc (windows) with your bridge information. Here’s a config you can try first:

Bridge obfs4 C53157B0E2B8FD1691D16D2E47F9BE6FFB0AACDB cert=RSDfLF/ZlW9iVS4cQj1yZXdaQGlPDOertIeBeyTKh+5aF/oeS3qfzeXopn/ggumv29h0AA iat-mode=0
Bridge obfs4 03952DB97158994A8E00A25A98A474E74720A2E0 cert=AepF0GRGZCGKrpEAzdTRm7H39kooZkHoOAm2Mek9cHeU88ZBMEBSvryOgW1BrjR8eRnGag iat-mode=0
Bridge obfs4 35DDA17498E9F8E5E0922D4BA405408FFE699371 cert=d6Mk1f50CqR9xlEu0ZoPleclmuvZa0SysP+nEj2c3d6eiCf/JTG2erNjtmBTVI/M0TX+VA iat-mode=0
UseBridges 1
ClientTransportPlugin obfs4 exec PluggableTransports/obfs4proxy

Let me know, please.

I created the .torrc file. and rebooted the Virtual Machine. But adress is not showing. I think a view days ago when I ran Grin++ v1.0.2 there was an address showing.

Is it possible to send grin to the same wallet?
When I try to open my .tx file. Grin++ writes “Failed to verify received slate. (filename.tx)”

Mmmm… are you sure you placed the file in the correct path? is your Antivirus blocking Tor?

If this is the correct path.


there is an other directory


I use Linux not aware of any Antivirus.

Just for testing I started Grin++ v1.0.2 again. It starts without failure and it shows an address.

No need for the .torrc file. I would remove that. It’s only for cases where you get an address, but it’s not accessible (blocked by your ISP).

After removing the .torrc, close Grin++, and kill tor.exe if it’s still running. Then reopen and login and you should be fine.

@Doogevol any update on this?

No updates.
initial problem solved. (Grin++ v1.0.2 runs fine again)
Grin++ v1.0.5 runs too but doesn’t show address.
.torrc file or not, no difference recognized.

Is there an option to connect to a specific (LAN) node?

Mmmm would you mind joining the Telegram Grin++ channel? Maybe someone else with the same problem could help.

Mmmm I would mind. In my (limited) point of view telegram is a data leech.