[solved] Grin-Miner won't run UBUNTU SERVER 16.04

~/source/grin-miner/target/debug$ grin-miner
thread ‘main’ panicked at ‘called Option::unwrap() on a None value’, libcore/option.rs:355:21
note: Run with RUST_BACKTRACE=1 for a backtrace.

any ideas? thx

You are missing the “grin-miner.toml” file in your grin-miner binaries directory.

Thanks for the answer, was i supposed to generate this somehow? Not sure why i don’t have one?

Copy the file from ~/grin-miner$ to ~/grin-miner/target/debug$ directory

Done, thanks!

but now it gets killed a second or two after running grin-miner from the debug dir

the ui remains on the screen, but i can see the cursor line come back and above it and to the right poking through the ui i can see the word ‘killed’

not sure what’s rthe problem

Try to compile a new copy from github.
There is updates…

still not working, perhaps it’s crashing because system only has 4gb ram and old cpu?

Check your grin-miner.log for possible more diagnostics about the crash.

Good advice tromp.

For active monitoring of logfile use “tail -f grin-miner.log”

ok here is my tail wink:

Jan 05 19:25:00.496 INFO This is Grin-Miner version 0.5.0 (git v0.5.0), built for x86_64-unknown-linux-gnu by rustc 1.31.1 (b6c32da9b 2018-12-18).
Jan 05 19:25:00.499 DEBG Built with profile “debug”, features “DEFAULT” on Sat, 05 Jan 2019 20:15:51 GMT.
Jan 05 19:25:00.505 DEBG Starting solvers
Jan 05 19:25:00.505 DEBG Loading miner plugin: /home/test/source/grin-miner/target/debug/plugins/cuckaroo_cpu_compat_29.cuckooplugin
Jan 05 19:25:00.517 DEBG Loading miner plugin: /home/test/source/grin-miner/target/debug/plugins/cuckaroo_cpu_compat_29.cuckooplugin
Jan 05 19:25:01.536 WARN Connection Status: Connected to Grin server at
Jan 05 19:25:01.546 DEBG sending request: {“id”:“0”,“jsonrpc”:“2.0”,“method”:“getjobtemplate”,“params”:null}


I was ssh’-ing into that machine.,…
when I run if from the machine directly it crashes in the same way… with the ascii ui still painted in the terminal, but i can see much more information , here is a picture

When i start “./grin-miner --floonet” the miner app uses 3,7 GB of memory.

Your problem is your memory, you need more.
The second line of your fault message is “Out of memory”

if i mine with a GPU can i get away with my current memory? 4 GB ?

“babaji: if i mine with a GPU can i get away with my current memory? 4 GB ?”

Sorry, I don’t know…

are u mining with a cpu or a gpu?

I’m CPU mining…

I don’t have any functional GPU card for mining… :frowning:

All i have are a bunch of 4gb amd’s doing Monero, i was hoping to reassign a couple for Grin. unfortunately they don’t have enough memory to participate, and no miner support yet.

So against my better judgement i went out and bought a 2080 this evening. This will be the last graphics card I ever buy, i swear!

ok success…

problem was i had no swap disk, (for some misguided reason, i have not been using swap partitions hoping to save my cheapo ssd’s from abuse)

so i made a swap file and it started right up

i have mined a handful of different coins / algorithms and this is the first time 4gb was not enough

Thanks everyone, I am going to stare at this for a while and see if i can make heads or tails of all these systems…

So did you successfully mine at 4GB?