Fatal runtime error: failed to initiate panic, error 5 when starting grin miner


After building and installing grin-miner 1.0.2, i have this error when initiating



Run with RUST_BACKTRACE=1 and provide the output

RUST_BACKTRACE=1 ./target/release/grin-miner

What version of Ubuntu? What version of rustc? If you just download the pre-built images, does grin-miner work?

If I run that command from grin-miner directory, I get the same screen output.

If I run within target directory I get this:

rustc version is 1.3.0

Ubuntu is 18.04.1 LTS

Where can I get the pre-built images? Haven’t tried it.

The error that you get when running within the target directory is because there is no “grin-miner.toml” in that directory - a different issue than the one you reported.

rustc 1.3.0 ? Do you mean 1.30.0? Regardless 1.30.0 is kind of dated - it is from October. Current version is 1.32.0 No idea though if that is the cause of your problem.

prebuild grin-miner is at https://github.com/mimblewimble/grin-miner/releases/latest


Tried the pre-built image, it runs a few seconds then got a "killed’ message.

I also checked on grin-miner.log and I have this

Btw, Im on a Digital Ocean VPS with 2 vCPU and 1GB ram.

I also tried the same on my laptop running on VirtualBox linux, the result is it freezes the VM.


1GB of RAM will not be enough memory. Try 4GB of RAM. (P.S. Out of the box and not making any changes to grin-miner.toml you are mining with your CPU which is what the output you attached is showing.)

I see. thanks for the support.

I am complete noob to mining and I got the exact same error and it is crashing. Please help with next steps.


By exact same error do you mean, “Killed” ? You need more RAM and/or more swap space.

Yes, fatal runtime error: failed to initiate panic, error 5
Running Ubuntu on VM. My machine has sufficient RAM. How do I allocate more to Ubuntu?

Two different and unrelated problems in this thread.

"Killed" ==> need more memory
"Fatal runtime error: failed to initiate panic, error 5 when starting grin miner"

Did you initially run grin as root or using the sudo command and are now running as a normal user?

Ran it as a normal user and the miner as a normal user as well.

Okay. I haven’t got a clue. error 5 is Input/output error so I was guessing ownership or permission problems with the files under the .grin directory.

I increased the memory and it is working great now, thanks!