Niffler, An out-of-the-box open sourced Grin GUI Wallet

This is great, as a newb to Grin I appreciate anything driven towards to GUI, as much as I was eager to learn about Grim, I found, as a newb, that it is really Linux focused giving it an even higher level of entry.

yes, one of remote node shutdown unexpected. sorry
now it started.

should be ok

if you are in european, maybe you cloud use @mcm-mike’s http://grinnode.live/ as remote node.

2 Likes

Yes I am in Europe. I read the instructions and solved. Thank you

1 Like

Can somebody with balance in his Niffler wallet send me a screenshot of how the wallet outputs a slatepack message? Just copy your own address, try to send to it, and take a screenshot when the wallet shows the slatepack. Then cancel the transaction.

Would be much appreciated!

screenshoot sent
…20char…

1 Like

mate I cannot access my wallet since update.
It tells me that I am entering invalid seed phrase.
But I am 100% sure its good. I´ve been recovering many times.
Now it doesnt work. Is there any issue on new wallet.
Cuz first I only updated the wallet, enter password but was unable to access.
So I have removed current and tried to recover after reinstall. Please let me know, thanks.

which os are you using? mac or windows?
send me log to xiaojay@gmail.com
the log located on ~/.niffler/log if you are mac;
c:/users/[your username]/.niffler/log if you are windows.

Ok, posted, hope it will help.

Niffler v0.6.1 is available

A bug fix/some improvement version of Niffler wallet v0.6.1, which update Grin node to v0.4.1;
And thanks to @Kinaou , French version of Niffler is available :slight_smile:

4 Likes

Hi @xiaojay , I try to withdrawn grin from polo, using latest niffler.

I usred hedwig, and polo saids witradawn is completed, but on niffler i see that transaction, but is still unconfirmed, I did not close wallet, and green light is near hedwig.

Its been longer than 10 min and still not successfull, is this normal wait time or I should not use hedwig?

Edit: 3h+ passed, and still unconfirmed, ballance unchanged

I just saw my local node is not in sync, if I remove Current chain Data and sync from scratch will I loose this transaction its been 8h+ still no coins, its not finalized.

Yes you can remove chain data and re-sync from scratch, it’ll probably solve it. No chance to lose your funds this way.

Also, you can connect to a remote node (e.g. grinnode.live) at the detriment of some privacy and trust.

2 Likes

Thank you, but I think this has to do with network or something.
Firewall is allowed to niffler,
This is error I got in logs, and it keeps repeting

2020-10-16 22:58:15:719 [debug] hedwig succesful with url: https://9xxxxx432.v1.hedwig.im
2020-10-16 22:58:24:406 [debug] Try to test if http listen locally reachable?
2020-10-16 22:58:24:418 [debug] Http listen is locally reachable.
2020-10-16 22:58:24:427 [debug] Try to test internet reachalbe: https://9xxxx432.v1.hedwig.im ?
2020-10-16 22:58:25:497 [debug] receive data from hedwig
2020-10-16 22:58:25:718 [debug] connect https://9xxxxxxx34432.v1.hedwig.im return: Error: Request failed with status code 404
These are some SS from Niffler app
https://prnt.sc/v15u91

Do you think if I try to restore my wallet with grin ++ can that transaction be ‘resumed’ over there?

EDIT: there are some changes, now Height (local): 393874 , before is 0.
But now when I go to Recive via Hedwig (becouse it saids it needs to be online) the address is different than the one from yesterdays one that coins were send to.
Can I change that to old address from yesterday, maybe coins can now reach my wallet and finish this transaction.

If there was a problem with building the transaction (hedwig/http) then you didn’t get the coins and you likely need to contact Poloniex about it.

But ye, before you do that I’d first suggest to restore your wallet and see if perhaps you did receive them. You can just download grin-wallet and use command grin-wallet scan, since you already have a grin node synced and running (if you do it via Grin++ you’ll have the sync the whole chain again).

2 Likes

Try more (rightup corner) -> check balance.

If the balance dose not show up correctly, try to contact polo exchange

Hi, thank you for reaching out.

Polo just send me this

I did the check ballance and nothing new happened.

If anything matters, height (local) is almost always 0, untill i downloaded grin ++, and when I turn on both wallets then height (local) gets big numbers.

Don’t run Niffler and Grin++ at the same time, it always causes issues. If you open Grin++, make sure the kill the grin node task that niffler runs in the background.

What do you mean?
Is your niffler wallet connected to a local or remote node?

1 Like

Local node, default settings.
When I installed niffler, height was 0 all the time.
After trying all options and failed with niffler I downloaded grin ++, then the height automaticly goes big numbers.

1 Like

Grin++ and Niffler interfere with each other in very annoying ways. I suggest you completely delete both of them, then re-download one. There’s probably another way to resolve the conflict, but it’s not as simple.

Alternatively, choose “Use remote all the time” and use https://grinnode.live:3413 as a remote node. See if that allows you to scan without errors.

2 Likes

hello, your remote grin node is wrong。
change it to http://grin-node.niffler.org:3413
or if you are in european, change it to https://grinnode.live:3413 is ok, like @Paouky suggest.

1 Like

Thank you, as soon as I changed remote grin to european, all was ok. Thank you guys.