"Grin Pie" - build fails when compiling `grin_store`

I ran into trouble compiling Grin node on a Raspberry Pi 3 B+. (64 arm architecture + 64 gig SD card)
The build fails when compiling grin_store

I read to limit your state storage to 2^32 bytes, but not sure how to do that?

I tried again this morning using the latest version released yesterday however I’m still getting the build failure at grin_store. Any suggestions for my GrinPie would be appreciated.

The main problem is that Rasbian (default Raspberry Pi OS) is 32bit, where Grin is programmed with 64-bit only components. Best option is to use something like Ubuntu Server (64-bit ARM) on the GrinPie and then hope it compiles (I have not tried yet).

1 Like

Thanks, I will give that a try.

Ubuntu does not want to work also tried the server version and it failed to load on the pi.

So, I am using a new Raspberry Pi 3+ and it is 64-bit with Rasbian I am able to set up the firewall, update rust, grin install runs, everything goes smooth then fails at the last inch at the grin_store. Does anyone know a command to run the install for 64-bit architecture?

I 2nd that. I want to use my GrinPi as my Grin Hot Wallet.

1 Like

I tried this recently but it didn’t work for me, it might be the SD card or the mac file to linux issue on my side? It could be worth it to try on your GrinPi?: https://github.com/bamarni/pi64/releases/

1 Like

Will get back to it ASAP.

Same here I have not given up, going to buy fresh sd cards this weekend. I will share what I come up with.

I am going with Ubuntu btw: https://www.raspberrypi.org/forums/viewtopic.php?t=220079

Thank you so much for sharing. I didn’t know that last part:

To get rid of the boot errors from grub because of missing .mod files copy the files from
https://packages.debian.org/jessie/arm6 … n/download
to (part1)/boot/grub/arm64-efi/

If your Pi hangs at the rainbow screen when booting one of these images, it means one of the following:

  • You are using an incompatible Pi model. Ubuntu ARM64 only works on Pi’s with the BCM2837 SoC.
  • Your power supply isn’t strong enough.

@Grin1 were you ultimately able to compile RUst and all on the RPI ?

I was thinking the rock pi might be a better way to go. I have gridseed miners that plug into the pi.
I’ve been busy with work and put it on my to do list: