Grin Node freezes in TUI mode - v5.1.2


I run a Grin Node in TUI mode using Ubuntu and screen.
Installed is version 5.1.2 - Due to github release notes the TUI issue should be fixed.

The connected miners disconnect randomly after working a few hours.
Have to restart the node several times until it is working properly.

TUI in combi with Ubuntu screen seems not to be a stable combo?

What if I would run Grin node without TUI - do I have to parse logs to get amount of shares and other mining infos?

I would try running the latest version, v5.2.0-alpha.2. I think this issue is fixed there.


Thought of this option aswell, but the “alpha” tag, dont know does not sound clean.

Agree, works much more stable in my experience.


Thanks will upgrade to latest node version.

Any xp how to update the node version on linux? I tried to remove the .grin folder but grin command instant restore it. Is there a way to update via command line?

As far as I understand, if you update, you only need to replace the binary. You do not even need to remove the ./grin folder.

So I think it is as simple as 1) removing the grin binary file/executable 2) going to the github page, downloading the .zip or .tar file and extracting it, in which you will find the grin binary.

  1. running the binary which is now the latest version means you updated. In case this gives you errors, just remove the ./grin folder and try again.

In case you need to compile your own version of the wallet and node for and ARM chip, read below

On custom linux ARM chip, e.g. Raspberry Pi

1) Install rust

sudo curl --proto '=https' --tlsv1.2 -sSf | sh

-Restart command line to upload your path variabel, otherwise cargo build will not work

sudo apt install build-essential git tor cmake git libgit2-dev clang libncurses5-dev libncursesw5-dev zlib1g-dev pkg-config libssl-dev llvm

(Credits: Build - Grin Documentation)

2) Install the grin node

git clone
cd grin
cargo build

Look in /target/release to get the binary file (grin), copy it to a convenient place such as your home folder, this is the node binary, run via command line ./grin

3) Now install the grin-wallet

git clone
cd grin-wallet
cargo build --release

Look in /target/release or in case of errors in /target/debug to get the binary file (gin-wallet), copy it to a convenience place, this is the wallet binary,
-run in listening mode for incoming transactions with: ./grin-wallet listen
-Or if you do not have a wallet yet: ./grin-wallet init
-Or if you need to recover from seed: ./grin-wallet init -r


Thanks for help. In my case it worked to download latest version from github and add it to
tar -C /usr/local/bin -xzf grin-$VERSION-linux-amd64.tar.gz --strip-components=1

Updated the bin as you mentioned.

1 Like

At this case you need to build it with:

cargo build --release
1 Like

A reason for TUI freeze is starting the server at main thread, I experienced same problem at my app, it can take up to 1 minute at debug release to start the server with finished sync state, problematic call is: chain::setup_head.
At my app I just moved server creation to separate thread to avoid this, discussed this problem with @vegycslol also, I guess we can solve it by launching server at another thread or optimize setup_head function somehow.
P.S. At my build I used 5.1.2 too as last available version from

5.2.0-alpha.2 runs stable now with TUI

1 Like

In the latest Linux tar.gz v5.2.0-beta.2 seem to be a HTML file corrupting the download.

Someone has an idea to fix this?

Yeah it was the wrong path replaced /tag with /download