Grin-miner on M1 mac?

I am trying to compile grin-miner on M1 mac but not able to match builds with plugins…

Does anybody have a functional how-to?


and is it worth it - I mean does the M1 gets a workout ?

1 Like

What I was able to do is to run binary from git - compile of the code errored on me and then I tried to get the right OCL plugins work but then they do not match on architecture

PluginNotFoundError("/Users/martinvana/grinminer/prep/grin-miner/plugins/ocl_cuckaroo.cuckooplugin - DlOpen { desc: “dlopen(/Users/martinvana/grinminer/prep/grin-miner/plugins/ocl_cuckaroo.cuckooplugin, 0x0002): tried: \’/Users/martinvana/grinminer/prep/grin-miner/plugins/ocl_cuckaroo.cuckooplugin\’ (mach-o file, but is an incompatible architecture (have \‘arm64\’, need \‘x86_64\’)), \’/usr/local/lib/ocl_cuckaroo.cuckooplugin\’ (no such file), \’/usr/lib/ocl_cuckaroo.cuckooplugin\’ (no such file)” }")

I would say the binary is running in x86 mode but my plugins are compiled into arm64… it is a mess :slight_smile:

at the end compiled the ocl plugin as x86 as well and it seems to start.

But it probably means it is running through Rosetta2?

I’m interested in the results.
M1 can mine XMR and ETH with decent, but not superior power-efficiency.
Since the mac is high priced low power, it would take some decades until the electricity price reaches the hardware price.
M1 Max with 64GB (400GB/s) would maybe belong to the most power-efficient hardware to find bigger Cuckoo cycles.

I got this error CL_INVALID_WORK_GROUP_SIZE (-54)

I noticed grin and grin-wallet can now be compiled as native apple silicon but no luck on the grin-miner. Anybody knows how to compile it?