5.2.0-beta 2 glibc error

I’m running 22.04.2 LTS and I get this error:

grin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.32' not found (required by grin)

grin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.33' not found (required by grin)

grin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.34' not found (required by grin)

but also:

libc6 is already the newest version (2.31-0ubuntu9.9).

So do I need to upgrade ubuntu to a newer version?

Try to install all deps:

apt install build-essential cmake git libgit2-dev clang libncurses5-dev libncursesw5-dev zlib1g-dev pkg-config libssl-dev llvm

This machine was already running the alpha so I think I have all those but I’ll try reinstalling them.

Dependencies were indeed already all installed.

Upgrading to 20.04.6 LTS fixed it!

Wait no I’m back on 22.04.2 LTS I don’t know what I’ve done lol.

I ran sudo do-release-upgrade -d and followed through all the prompts.

Indeed last build requires GLIBC 2.32+ and not launching at distros like Debian 11, as it comes with 2.31 by default.

From forums:

If you need to upgrade glibc, the safest solution may be to upgrade your Linux distribution, since most software depends on glibc.

1 Like

I guess the problem is coming from CI, build changed since May, so it depends on recent LIBC for now:

Another solution is to build your own grin binary against GLIBC you need to use.

This problem is old:

1 Like