The current wallet uses these round names
for regular (sender-signs-last) flow, and
for invoice (receiver-signs-last) flow.
These names are somewhat arbitrary, and finalize has been criticized for not being an obvious necessity.
For invoice flow, the following names are more descriptive:
Is is possible to replace “payment” by another word that would be appropriate for regular flow?
I thought “invoice” might work, but hesitate to use that word in the non-invoice flow:-(
How about expense?
Btw, I hope that invoice flow becomes the standard, and reserve regular flow for cases where a high-volume transactor, such as an exchange, insists on being last-to-sign to minimize output locking.