Can't scan wallet?

I’m running Grin 4.0.0-alpha.1, and latest wallet, newly initialized a seed via “init -hr”, and now when I try to do ‘scan’, it say:

20200530 15:15:35.487 ERROR grin_wallet_controller::command - Backtrace:
Wallet command failed: LibWallet Error: Client Callback Error: Unable to parse response for get_pmmr_indices: JSON decode error: invalid type: null, expected struct OutputListing

I have no idea what this mean, halp?

Well, you see, you can’t provide null when an OutputListing is expected! Nice try. :slight_smile:

Seriously, though, I don’t know. @Yeastplume?

@betajuice does the issue persist when you run the latest stable version of node and wallet, i.e. v3.1.1?

FYI releases are available here:
https://github.com/mimblewimble/grin/releases,
https://github.com/mimblewimble/grin-wallet/releases

I’m not sure what the issue was, but I think it was because my grin node was not actually synced, the wallet seems to be working fine now

1 Like