# Grin node 0.5.1 sync issues

**URL:** <https://forum.grin.mw/t/grin-node-0-5-1-sync-issues/1871>\
**Category:** Tech Support\
**Created:** [January 8, 2019, 8:21pm UTC](https://forum.grin.mw/t/grin-node-0-5-1-sync-issues/1871 "2019-01-08T20:21:10Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![ap08](https://avatars.discourse-cdn.com/v4/letter/a/c57346/32.png) [@ap08](https://forum.grin.mw/u/ap08)\
**Post date:** [January 8, 2019, 8:21pm UTC](https://forum.grin.mw/t/grin-node-0-5-1-sync-issues/1871/1 "2019-01-08T20:21:11Z")

</div>

I’m trying to sync a grin node on floonet and it keeps getting hung up on step 1/4 downloading headers.

 ![Screenshot_2019-01-08_04-16-11](https://canada1.discourse-cdn.com/flex036/uploads/grin/original/1X/36db8686105dcc27b04b24a8234389c7ce222424.png)

When I run the log, I see the following series:

20190107 17:33:16.260 DEBUG grin\_chain::chain - body\_sync: body\_head - edc758c1, 0, header\_head - 0104492c, 14592, sync\_head - 0104492c, 14592  
20190107 17:33:16.451 DEBUG grin\_chain::chain - body\_sync: need a state sync for txhashset. oldest block which is not on local chain: 026ea624 at 1  
20190107 17:33:16.451 DEBUG grin\_servers:😁:sync::body\_sync - body\_sync: cannot sync full blocks earlier than horizon. will request txhashset  
20190107 17:33:16.461 DEBUG grin\_servers:😁:sync::body\_sync - body\_sync: no pending block request, asking more

Can anyone help me diagnose this problem? Did I miss a step in config?

FYI I’m running Manjaro / Arch Linux (latest version)

Thank you in advance for your help.

Cheers,  
Alex

---

<div class="post-metadata">

**Author:** ![igno.peverell](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.grin.mw/igno.peverell/32/4_2.png) [@igno.peverell](https://forum.grin.mw/u/igno.peverell)\
**Post date:** [January 8, 2019, 11:00pm UTC](https://forum.grin.mw/t/grin-node-0-5-1-sync-issues/1871/2 "2019-01-08T23:00:51Z")

</div>

This should now start downloading the whole chain state as one big file. Any other occurrence of the word txhashset in your logs? Do you have a slow connection? Status should update once in a while telling you about said download.

---

<div class="post-metadata">

**Author:** ![ap08](https://avatars.discourse-cdn.com/v4/letter/a/c57346/32.png) [@ap08](https://forum.grin.mw/u/ap08)\
**Post date:** [January 9, 2019, 4:11am UTC](https://forum.grin.mw/t/grin-node-0-5-1-sync-issues/1871/3 "2019-01-09T04:11:12Z")

</div>

So I have the node running now, but the chain height is stuck at 0. When I start the server, I have about 10 peers, but all connections are outbound. The number slowly ticks down to one or two (both of which have a chain height of 0). Is there any reason why I might not be able to connect to peers. I’ve already followed the steps here except I haven’t removed peers directory yet (which I found in chain-data…not sure if that is the one):

> [@Debugging sync issues](https://forum.grin.mw/t/debugging-sync-issues/145):
>
> You’re either starting a brand new Grin testnet node, or have been running it for some time but it doesn’t seem to be updating with latest blocks anymore. First, make sure you’re running a recent version of the code. If your build is more than a couple weeks old, update and retry. If you’re up-to-date, check the head of your local chain: curl localhost:13413/v1/chain Compare the resulting height and hash with: [Grin Explorer](https://grinexplorer.net/)[Grin Scan](https://grinscan.net/) If you’re really late on the chain and not updating, her…

Here are the relevant screenshots:

 ![Screenshot_2019-01-08_12-16-26](https://canada1.discourse-cdn.com/flex036/uploads/grin/original/1X/98e841e3da4b99767e0daeb45b910ac2bdcaa49d.png)

 ![Screenshot_2019-01-08_12-16-42](https://canada1.discourse-cdn.com/flex036/uploads/grin/original/1X/3bf54ba459f912169557eb7f0c80eaf10046a2f9.png)

UPDATE: added hard-coded peers according to the post [here](https://forum.grin.mw/t/issue-syncing-grin-node-0-4-2/1588/9). Still running into the same issue.

---

<div class="post-metadata">

**Author:** ![Lupin](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.grin.mw/lupin/32/816_2.png) [@Lupin](https://forum.grin.mw/u/Lupin)\
**Post date:** [January 9, 2019, 10:42am UTC](https://forum.grin.mw/t/grin-node-0-5-1-sync-issues/1871/4 "2019-01-09T10:42:02Z")

</div>

Hello,  
Like many, I want also to install a node.  
What’s the recommended version to install now ?  
is it fine with v0.5.1 , or too risky ?  
It will be on Debian 9.6 64bits 16GB.

PS: Thanks to the devs for all the great work.

---

<div class="post-metadata">

**Author:** ![ap08](https://avatars.discourse-cdn.com/v4/letter/a/c57346/32.png) [@ap08](https://forum.grin.mw/u/ap08)\
**Post date:** [January 9, 2019, 5:14pm UTC](https://forum.grin.mw/t/grin-node-0-5-1-sync-issues/1871/5 "2019-01-09T17:14:31Z")

</div>

It looks like I keep losing the connection with the other nodes as I’m syncing. Looking through the logs, I keep having the following error:

20190108 13:15:52.229 DEBUG grin\_p2p::peer - Client 35.246.154.78:13414 connection lost: Connection(Custom { kind: ConnectionAborted, error: StringError(“read\_exact”) })

---

<div class="post-metadata">

**Author:** ![Lupin](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.grin.mw/lupin/32/816_2.png) [@Lupin](https://forum.grin.mw/u/Lupin)\
**Post date:** [January 10, 2019, 2:52pm UTC](https://forum.grin.mw/t/grin-node-0-5-1-sync-issues/1871/6 "2019-01-10T14:52:57Z")

</div>

I installed grin v0.5.1 on a Debian 9.6 16GB.  
Install seems successfull, and grin --help, grin server help, grin wallet help, returns what expected

But when I run

> grin --floonet

just nothing happens  
There is even no grin process running ?

What I’m missing ?

---

<div class="post-metadata">

**Author:** ![ap08](https://avatars.discourse-cdn.com/v4/letter/a/c57346/32.png) [@ap08](https://forum.grin.mw/u/ap08)\
**Post date:** [January 10, 2019, 2:57pm UTC](https://forum.grin.mw/t/grin-node-0-5-1-sync-issues/1871/7 "2019-01-10T14:57:17Z")

</div>

Did you adjust any of the settings in the .toml file?

---

<div class="post-metadata">

**Author:** ![Lupin](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.grin.mw/lupin/32/816_2.png) [@Lupin](https://forum.grin.mw/u/Lupin)\
**Post date:** [January 10, 2019, 3:16pm UTC](https://forum.grin.mw/t/grin-node-0-5-1-sync-issues/1871/8 "2019-01-10T15:16:53Z")

</div>

Thanks for the advice.  
No I didn’t touch any of those .toml settings (but I’ll have a look).

Here is grin-server.log:

```
20190110 16:01:17.407 INFO grin_util::logger - log4rs is initialized, file level: Debug, stdout level: Warn, min. level: Debug
20190110 16:01:17.407 INFO grin - Using configuration file at /home/userz/.grin/floo/grin-server.toml
20190110 16:01:17.407 INFO grin - This is Grin version 0.5.1 (git v0.5.1), built for x86_64-unknown-linux-gnu by rustc 1.31.1 (b6c32da9b 2018-12-18).
20190110 16:01:17.407 DEBUG grin - Built with profile "release", features "".
20190110 16:01:17.407 WARN grin::cmd::server - Starting GRIN in UI mode...
20190110 16:01:17.407 INFO grin_servers::grin::server - Starting server, genesis block: edc758c1
20190110 16:01:17.443 DEBUG grin_chain::txhashset::txhashset - Error returned, discarding txhashset extension: Other Error: output vs rproof MMRs different sizes 
 Cause: Unknown 
 Backtrace: 
20190110 16:01:17.463 ERROR grin_util::logger - 
thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: Chain(Error { inner: 

Other Error: output vs rproof MMRs different sizes })': libcore/result.rs:1009stack backtrace:
   0: 0x563a258ce65d - backtrace::backtrace::trace::hd74837959dc31a2c
etc
```
